Get Even More Visitors To Your Blog, Upgrade To A Business Listing >>

MPLS-TE task #1. Configuring simple MPLS-TE tunnels part 1.

Topology:



Configure loopback0 interfaces and links between the routers for initial configuration.
Router R3 and R4 are IOS-XR routers, the rest are IOS.

Requirements: 

1. Configure ISIS to provide routing between all devices in the topology. Only create ISIS Level-2         database on all devices. 
    Configure MPLS-TE solution to achieve the following: 
2. Traffic sent from R1 to Loopback0 interface of R8 should use the following path:
     R1-> R2-> R6->R4-R8. All configuration related to path selection should be on R1. 
3. Traffic sent from R4 to Loopback0 interface of R7 should use the following path:
     R4->R5->R6->R1->R7. All configuration related to path selection should be on R4. 
4. In case the above path is not available due to router or link failure, the traffic shall be rerouted to         different path. 
5. All other traffic shall be routed - not MPLS switched. 
6. Do not alter ISIS metrics to affect path selection. 
      

Solution:

Highlight the text below to reveal the solution.

This task requires understanding of MPLS-TE configuration and MPLS-TE explicit-path. 
Note that LDP is not enabled and not running on any interface. 

Requirement #1 - on all routers, configure "is-type level-2-only"

Requirements #2 - #6 - 
                                       enable MPLS-TE on all routers
                                       enable MPLS-TE on all interfaces
                                       configure MPLS-TE under ISIS process for Level-2
                                       configure MPLS-TE tunnel from R1 to R4, with two path options - first with                                        explicit path, second dynamic. 
                                       configure MPLS-TE tunnel from R4 to R1, with two path options - first with                                        explicit path, second dynamic.
                                       configure static routes on R1 and R4 via the MPLS-TE tunnel. 
                                     


R1:

!
mpls traffic-eng tunnels
!
interface Loopback0
 ip address 25.0.1.1 255.255.255.255
 ip router isis CCIE
!
interface Tunnel14
 ip unnumbered Loopback0
 tunnel source Loopback0
 tunnel mode mpls traffic-eng
 tunnel destination 25.0.4.4
 tunnel mpls traffic-eng path-option 10 explicit name EVEN
 tunnel mpls traffic-eng path-option 100 dynamic
 no routing dynamic
!
interface Ethernet0/0
 ip address 25.0.12.1 255.255.255.0
 ip router isis CCIE
 mpls traffic-eng tunnels
!
interface Ethernet0/1
 ip address 25.0.16.1 255.255.255.0
 ip router isis CCIE
 mpls traffic-eng tunnels
!
interface Ethernet0/2
 ip address 25.0.13.1 255.255.255.0
 ip router isis CCIE
 mpls traffic-eng tunnels
!
!
interface Ethernet1/0
 ip address 25.0.17.1 255.255.255.0
 ip router isis CCIE
!
!
router isis CCIE
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-2
 net 49.0001.0000.0000.0001.00
 is-type level-2-only
 metric-style wide
!
ip route 25.0.8.8 255.255.255.255 Tunnel14
!
ip explicit-path name EVEN enable
 next-address 25.0.12.2
 next-address 25.0.26.6
 next-address 25.0.46.4
 next-address 25.0.4.4
!


R2:

mpls traffic-eng tunnels
!
interface Loopback0
 ip address 25.0.2.2 255.255.255.255
 ip router isis CCIE
!
interface Ethernet0/0
 ip address 25.0.12.2 255.255.255.0
 ip router isis CCIE
 mpls traffic-eng tunnels
!
interface Ethernet0/1
 ip address 25.0.26.2 255.255.255.0
 ip router isis CCIE
 mpls traffic-eng tunnels
!
interface Ethernet0/2
 ip address 25.0.23.2 255.255.255.0
 ip router isis CCIE
 mpls traffic-eng tunnels
!
interface Ethernet0/3
 ip address 25.0.25.2 255.255.255.0
 ip router isis CCIE
 mpls traffic-eng tunnels
!
!
router isis CCIE
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-2
 net 49.0001.0000.0000.0002.00
 is-type level-2-only
 metric-style wide
!


R3:

!
interface Loopback0
 ipv4 address 25.0.3.3 255.255.255.255
!
!
interface GigabitEthernet0/0/0/0
 ipv4 address 25.0.23.3 255.255.255.0
!
interface GigabitEthernet0/0/0/1
 ipv4 address 25.0.35.3 255.255.255.0
!
interface GigabitEthernet0/0/0/2
 ipv4 address 25.0.36.3 255.255.255.0
!
interface GigabitEthernet0/0/0/3
 ipv4 address 25.0.34.3 255.255.255.0
!
interface GigabitEthernet0/0/0/4
 ipv4 address 25.0.13.3 255.255.255.0
!
!
router isis CCIE
 is-type level-2-only
 net 49.0001.0000.0000.0003.00
 address-family ipv4 unicast
  metric-style wide
  mpls traffic-eng level-2-only
 !
 interface Loopback0
  address-family ipv4 unicast
  !
 !
 interface GigabitEthernet0/0/0/0
  address-family ipv4 unicast
  !
 !
 interface GigabitEthernet0/0/0/1
  address-family ipv4 unicast
  !
 !
 interface GigabitEthernet0/0/0/2
  address-family ipv4 unicast
  !
 !
 interface GigabitEthernet0/0/0/3
  address-family ipv4 unicast
  !
 !
 interface GigabitEthernet0/0/0/4
  address-family ipv4 unicast
  !
 !
!
mpls traffic-eng
 interface GigabitEthernet0/0/0/0
 !
 interface GigabitEthernet0/0/0/1
 !
 interface GigabitEthernet0/0/0/2
 !
 interface GigabitEthernet0/0/0/3
 !
 interface GigabitEthernet0/0/0/4
 !
!
mpls ldp
!

R4:

!
explicit-path name ODD
 index 1 next-address strict ipv4 unicast 25.0.45.5
 index 2 next-address strict ipv4 unicast 25.0.56.6
 index 3 next-address strict ipv4 unicast 25.0.16.1
 index 4 next-address strict ipv4 unicast 25.0.1.1
!
interface Loopback0
 ipv4 address 25.0.4.4 255.255.255.255
!
interface tunnel-te41
 ipv4 unnumbered Loopback0
 destination 25.0.1.1
 path-option 10 explicit name ODD
 path-option 100 dynamic
!
!
interface GigabitEthernet0/0/0/0
 ipv4 address 25.0.34.4 255.255.255.0
!
interface GigabitEthernet0/0/0/1
 ipv4 address 25.0.45.4 255.255.255.0
!
interface GigabitEthernet0/0/0/2
 ipv4 address 25.0.46.4 255.255.255.0
!
interface GigabitEthernet0/0/0/3
 shutdown
!
interface GigabitEthernet0/0/0/4
 ipv4 address 25.0.48.4 255.255.255.0
!
!
router static
 address-family ipv4 unicast
  25.0.7.7/32 tunnel-te41
 !
!
router isis CCIE
 is-type level-2-only
 net 49.0001.0000.0000.0004.00
 address-family ipv4 unicast
  metric-style wide
  mpls traffic-eng level-2-only
 !
 interface Loopback0
  address-family ipv4 unicast
  !
 !
 interface GigabitEthernet0/0/0/0
  address-family ipv4 unicast
  !
 !
 interface GigabitEthernet0/0/0/1
  address-family ipv4 unicast
  !
 !
 interface GigabitEthernet0/0/0/2
  address-family ipv4 unicast
  !
 !
 interface GigabitEthernet0/0/0/4
  address-family ipv4 unicast
  !
 !
!
mpls traffic-eng
 interface GigabitEthernet0/0/0/0
 !
 interface GigabitEthernet0/0/0/1
 !
 interface GigabitEthernet0/0/0/2
 !
!
mpls ldp
!



R5:

mpls traffic-eng tunnels
!
interface Loopback0
 ip address 25.0.5.5 255.255.255.255
 ip router isis CCIE
!
interface Ethernet0/0
 ip address 25.0.56.5 255.255.255.0
 ip router isis CCIE
 mpls traffic-eng tunnels
!
interface Ethernet0/1
 ip address 25.0.35.5 255.255.255.0
 ip router isis CCIE
 mpls traffic-eng tunnels
!
interface Ethernet0/2
 ip address 25.0.25.5 255.255.255.0
 ip router isis CCIE
 mpls traffic-eng tunnels
!
interface Ethernet0/3
 ip address 25.0.45.5 255.255.255.0
 ip router isis CCIE
 mpls traffic-eng tunnels
!
!
router isis CCIE
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-2
 net 49.0001.0000.0000.0005.00
 is-type level-2-only
 metric-style wide
!

R6:

mpls traffic-eng tunnels
!
interface Loopback0
 ip address 25.0.6.6 255.255.255.255
 ip router isis CCIE
!
interface Ethernet0/0
 ip address 25.0.16.6 255.255.255.0
 ip router isis CCIE
 mpls traffic-eng tunnels
!
interface Ethernet0/1
 ip address 25.0.26.6 255.255.255.0
 ip router isis CCIE
 mpls traffic-eng tunnels
!
interface Ethernet0/2
 ip address 25.0.56.6 255.255.255.0
 ip router isis CCIE
 mpls traffic-eng tunnels
!
interface Ethernet0/3
 ip address 25.0.36.6 255.255.255.0
 ip router isis CCIE
 mpls traffic-eng tunnels
!
interface Ethernet1/0
 ip address 25.0.46.6 255.255.255.0
 ip router isis CCIE
 mpls traffic-eng tunnels
!
!
router isis CCIE
 mpls traffic-eng router-id Loopback0
 mpls traffic-eng level-2
 net 49.0001.0000.0000.0006.00
 is-type level-2-only
 metric-style wide
!

R7:

!
interface Loopback0
 ip address 25.0.7.7 255.255.255.255
 ip router isis CCIE
!
interface Ethernet0/0
 ip address 25.0.17.7 255.255.255.0
 ip router isis CCIE
!
!
router isis CCIE
 net 49.0001.0000.0000.0007.00
 is-type level-2-only
 metric-style wide
!

R8:

!
interface Loopback0
 ip address 25.0.8.8 255.255.255.255
 ip router isis CCIE
!
interface Ethernet0/0
 ip address 25.0.48.8 255.255.255.0
 ip router isis CCIE
!
!
router isis CCIE
 net 49.0001.0000.0000.0008.00
 is-type level-2-only
 metric-style wide
!


Verification:


R7#            traceroute 25.0.8.8
Type escape sequence to abort.
Tracing the route to 25.0.8.8
VRF info: (vrf in name/id, vrf out name/id)
  1 25.0.17.1 1 msec 0 msec 0 msec
  2 25.0.12.2 [MPLS: Label 16 Exp 0] 6 msec 2 msec 3 msec
  3 25.0.26.6 [MPLS: Label 16 Exp 0] 2 msec 2 msec 2 msec
  4 25.0.46.4 3 msec 1 msec 3 msec
  5 25.0.48.8 3 msec 2 msec 6 msec

R8#        traceroute 25.0.7.7
Type escape sequence to abort.
Tracing the route to 25.0.7.7
VRF info: (vrf in name/id, vrf out name/id)
  1 25.0.48.4 2 msec 1 msec 1 msec
  2 25.0.45.5 [MPLS: Label 16 Exp 0] 7 msec 7 msec 4 msec
  3 25.0.56.6 [MPLS: Label 17 Exp 0] 5 msec 7 msec 4 msec
  4 25.0.16.1 5 msec 6 msec 5 msec
  5 25.0.17.7 4 msec 6 msec 5 msec


R2#       traceroute 25.0.6.6
Type escape sequence to abort.
Tracing the route to 25.0.6.6
VRF info: (vrf in name/id, vrf out name/id)
  1 25.0.26.6 1 msec 5 msec 5 msec

R2#       traceroute 25.0.4.4
Type escape sequence to abort.
Tracing the route to 25.0.4.4
VRF info: (vrf in name/id, vrf out name/id)
  1 25.0.23.3 3 msec
    25.0.25.5 0 msec
    25.0.26.6 6 msec
  2 25.0.34.4 3 msec
    25.0.45.4 1 msec
    25.0.46.4 2 msec

R1#             show mpls traffic-eng tunnels

Name: R1_t14                              (Tunnel14) Destination: 25.0.4.4
  Status:
    Admin: up         Oper: up     Path: valid       Signalling: connected
    path option 10, type explicit EVEN (Basis for Setup, path weight 30)
    path option 100, type dynamic

  Config Parameters:
    Bandwidth: 0        kbps (Global)  Priority: 7  7   Affinity: 0x0/0xFFFF
    Metric Type: TE (default)
    AutoRoute:  disabled  LockDown: disabled  Loadshare: 0        bw-based
    auto-bw: disabled
  Active Path Option Parameters:
    State: explicit path option 10 is active
    BandwidthOverride: disabled  LockDown: disabled  Verbatim: disabled


  InLabel  :  -
  OutLabel : Ethernet0/0, 16
  RSVP Signalling Info:
       Src 25.0.1.1, Dst 25.0.4.4, Tun_Id 14, Tun_Instance 2788
    RSVP Path Info:
      My Address: 25.0.12.1
      Explicit Route: 25.0.12.2 25.0.26.2 25.0.26.6 25.0.46.6
                      25.0.46.4 25.0.4.4
      Record   Route:   NONE
      Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
  History:
    Tunnel:
      Time since created: 1 days, 5 hours, 27 minutes
      Time since path change: 5 hours, 45 minutes
      Number of LSP IDs (Tun_Instances) used: 2788
    Current LSP:
      Uptime: 5 hours, 45 minutes
      Selection: reoptimization
    Prior LSP:
      ID: path option 100 [2787]
      Removal Trigger: reoptimization completed

LSP Tunnel ios_t41 is signalled, connection is up
  InLabel  : Ethernet0/1, implicit-null
  OutLabel :  -
  RSVP Signalling Info:
       Src 25.0.4.4, Dst 25.0.1.1, Tun_Id 41, Tun_Instance 5
    RSVP Path Info:
      My Address: 25.0.1.1
      Explicit Route:  NONE
      Record   Route:   NONE
      Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits



RP/0/0/CPU0:ios#           show mpls traffic-eng tunnels
Sat Jan 23 20:47:20.328 UTC


Name: tunnel-te41  Destination: 25.0.1.1  Ifhandle:0x580
  Signalled-Name: ios_t41
  Status:
    Admin:    up Oper:   up   Path:  valid   Signalling: connected

    path option 10,  type explicit ODD (Basis for Setup, path weight 30)
    path option 100,  type dynamic
    G-PID: 0x0800 (derived from egress interface properties)
    Bandwidth Requested: 0 kbps  CT0
    Creation Time: Fri Jan 22 15:27:53 2016 (1d05h ago)
  Config Parameters:
    Bandwidth:        0 kbps (CT0) Priority:  7  7 Affinity: 0x0/0xffff
    Metric Type: TE (default)
    Path Selection:
      Tiebreaker: Min-fill (default)
    Hop-limit: disabled
    Cost-limit: disabled
    Path-invalidation timeout: 45000 msec (default), Action: Tear (default)
    AutoRoute: disabled  LockDown: disabled   Policy class: not set
    Forward class: 0 (default)
    Forwarding-Adjacency: disabled
    Loadshare:          0 equal loadshares
    Auto-bw: disabled
    Fast Reroute: Disabled, Protection Desired: None
    Path Protection: Not Enabled
    BFD Fast Detection: Disabled
    Reoptimization after affinity failure: Enabled
    Soft Preemption: Disabled
  History:
    Tunnel has been up for: 05:58:12 (since Sat Jan 23 14:49:08 UTC 2016)
    Current LSP:
      Uptime: 05:23:50 (since Sat Jan 23 15:23:30 UTC 2016)
    Prior LSP:
      ID: 4 Path Option: 100
      Removal Trigger: reoptimization completed

  Path info (IS-IS CCIE level-2):
  Node hop count: 3
  Hop0: 25.0.45.5
  Hop1: 25.0.56.5
  Hop2: 25.0.56.6
  Hop3: 25.0.16.6
  Hop4: 25.0.16.1
  Hop5: 25.0.1.1

LSP Tunnel 25.0.1.1 14 [2788] is signalled, Signaling State: up
  Tunnel Name: R1_t14 Tunnel Role: Tail
  InLabel: GigabitEthernet0/0/0/2, implicit-null
  Signalling Info:
    Src 25.0.1.1 Dst 25.0.4.4, Tun ID 14, Tun Inst 2788, Ext ID 25.0.1.1
    Router-IDs: upstream   25.0.6.6
                local      25.0.4.4
    Bandwidth: 0 kbps (CT0) Priority:  7  7 DSTE-class: 0
    Soft Preemption: None
    SRLGs: not collected
    Path Info:
      Incoming Address: 25.0.46.4
      Incoming:
      Explicit Route:
        Strict, 25.0.46.4
        Strict, 25.0.4.4

      Record Route: Disabled
      Tspec: avg rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
      Session Attributes: Local Prot: Not Set, Node Prot: Not Set, BW Prot: Not Set
                          Soft Preemption Desired: Not Set
    Resv Info: None
      Record Route: Disabled
      Fspec: avg rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
Displayed 1 (of 1) heads, 0 (of 0) midpoints, 1 (of 1) tails
Displayed 1 up, 0 down, 0 recovering, 0 recovered heads



R2#show mpls traffic-eng tunnels

LSP Tunnel R1_t14 is signalled, connection is up
  InLabel  : Ethernet0/0, 16
  OutLabel : Ethernet0/1, 16
  RSVP Signalling Info:
       Src 25.0.1.1, Dst 25.0.4.4, Tun_Id 14, Tun_Instance 2788
    RSVP Path Info:
      My Address: 25.0.26.2
      Explicit Route: 25.0.26.6 25.0.46.6 25.0.46.4 25.0.4.4
      Record   Route:   NONE
      Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
    RSVP Resv Info:
      Record   Route:   NONE
      Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits


R1#show mpls interfaces
Interface              IP            Tunnel   BGP Static Operational
Ethernet0/0            No            Yes      No  No     Yes
Ethernet0/1            No            Yes      No  No     Yes
Ethernet0/2            No            Yes      No  No     Yes
Tunnel14               No            No       No  No     Yes



This post first appeared on CCIE Service Provider Workbook, please read the originial post: here

Share the post

MPLS-TE task #1. Configuring simple MPLS-TE tunnels part 1.

×

Subscribe to Ccie Service Provider Workbook

Get updates delivered right to your inbox!

Thank you for your subscription

×