Get Even More Visitors To Your Blog, Upgrade To A Business Listing >>

L3VPN task 11. Simple MVPN.

Topology:



Configure loopback0 interfaces and links between routers for initial configuration.

AS23 is the service provider, offering L3VPN and MVPN service.
Routers R6, R7 and R8 are Customer-A routers, interconnected via AS23.

Requirements: 

1. Configure AS23 network: 
          1.1 Use single area OSPF ( area 0 ). 
          1.2 Minimize the amount of iBGP sessions, but ensure redundancy in case of router failure. 

2. Configure unicast L3VPN service for Customer-A
          2.1 each customer site is allocated a /24 prefix according to topology diagram. 
          2.2 use static routing to provide unicast connectivity between customer sites. 

3. Configure MVPN service for Customer-A
          3.1 AS23 shall use multicast group 239.0.1.1 to transport Customer-A multicast traffic. 
          3.2 AS23 configuration shall provide redundancy for case of router failure
          3.2 only use PIM-SM
          3.3 only use standards-based protocol to distribute RP information when required

To test the configuration, subscribe to multicast group 239.10.10.10 on R7 loopback0 and R8 loopback0 interfaces. Send multicast traffic from R6 loopback0 interfaces. Verify that both R7 and R8 receive the traffic. 

Solution:

Highlight the text below to reveal the solution.

This task requires understanding of MVPN configuration (Draft-Rosen).
For this task, only default MDT is required.

Requirement #1 - Configure two route-reflectors in order to minimize the amount of iBGP sessions                                  and provide redundancy. Note that two route-reflectors must have different cluster-                              id.

Requirement #3 - Configure MVPN with default MDT group only, as no switching to data MDT is                                  required. Use BSR to distribute RP information both in AS23 and in Customer A                                  networks. In AS23, configure two RP candidates and two BSR candidates to                                        provide redundancy.


R1: 


!
vrf definition CUST_A
 rd 100:100
 route-target export 100:100
 route-target import 100:100
 !
 address-family ipv4
  mdt default 239.0.1.1
 exit-address-family
!
ip multicast-routing
ip multicast-routing vrf CUST_A
!
!
interface Loopback0
 ip address 23.0.1.1 255.255.255.255
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface Ethernet0/0
 ip address 23.0.15.1 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface Ethernet0/1
 ip address 23.0.13.1 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface Ethernet0/2
 ip address 23.0.12.1 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface Ethernet0/3
 ip address 23.0.14.1 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface Ethernet1/0
 vrf forwarding CUST_A
 ip address 23.0.16.1 255.255.255.0
 ip pim sparse-mode
!
!
router ospf 1
 mpls ldp autoconfig
 router-id 23.0.1.1
!
router bgp 23
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 neighbor 23.0.3.3 remote-as 23
 neighbor 23.0.3.3 update-source Loopback0
 neighbor 23.0.5.5 remote-as 23
 neighbor 23.0.5.5 update-source Loopback0
 !
 address-family ipv4
 exit-address-family
 !
 address-family vpnv4
  neighbor 23.0.3.3 activate
  neighbor 23.0.3.3 send-community both
  neighbor 23.0.5.5 activate
  neighbor 23.0.5.5 send-community both
 exit-address-family
 !
 address-family ipv4 vrf CUST_A
  redistribute connected
  redistribute static
 exit-address-family
!
ip route vrf CUST_A 10.0.6.0 255.255.255.0 23.0.16.6
!


R2: 

!
vrf definition CUST_A
 rd 100:100
 route-target export 100:100
 route-target import 100:100
 !
 address-family ipv4
  mdt default 239.0.1.1
 exit-address-family
!
ip multicast-routing
ip multicast-routing vrf CUST_A
!
!
interface Loopback0
 ip address 23.0.2.2 255.255.255.255
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface Ethernet0/0
 ip address 23.0.25.2 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface Ethernet0/1
 ip address 23.0.23.2 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface Ethernet0/2
 ip address 23.0.12.2 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface Ethernet0/3
 ip address 23.0.24.2 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface Ethernet1/0
 vrf forwarding CUST_A
 ip address 23.0.27.2 255.255.255.0
 ip pim sparse-mode
!
!
router ospf 1
 mpls ldp autoconfig
 router-id 23.0.2.2
!
router bgp 23
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 neighbor 23.0.3.3 remote-as 23
 neighbor 23.0.3.3 update-source Loopback0
 neighbor 23.0.5.5 remote-as 23
 neighbor 23.0.5.5 update-source Loopback0
 !
 address-family ipv4
 exit-address-family
 !
 address-family vpnv4
  neighbor 23.0.3.3 activate
  neighbor 23.0.3.3 send-community both
  neighbor 23.0.5.5 activate
  neighbor 23.0.5.5 send-community both
 exit-address-family
 !
 address-family ipv4 mdt
  neighbor 23.0.3.3 activate
  neighbor 23.0.3.3 send-community extended
  neighbor 23.0.5.5 activate
  neighbor 23.0.5.5 send-community extended
 exit-address-family
 !
 address-family ipv4 vrf CUST_A
  redistribute connected
  redistribute static
 exit-address-family
!
ip route vrf CUST_A 10.0.7.0 255.255.255.0 23.0.27.7
!

R3: 

!
interface Loopback0
 ipv4 address 23.0.3.3 255.255.255.255
!
!
interface GigabitEthernet0/0/0/0
 ipv4 address 23.0.35.3 255.255.255.0
!
interface GigabitEthernet0/0/0/1
 ipv4 address 23.0.13.3 255.255.255.0
!
interface GigabitEthernet0/0/0/2
 ipv4 address 23.0.23.3 255.255.255.0
!
interface GigabitEthernet0/0/0/3
 ipv4 address 23.0.34.3 255.255.255.0
!
!
router ospf 1
 router-id 23.0.3.3
 area 0
  interface Loopback0
  !
  interface GigabitEthernet0/0/0/0
   network point-to-point
  !
  interface GigabitEthernet0/0/0/1
   network point-to-point
  !
  interface GigabitEthernet0/0/0/2
   network point-to-point
  !
  interface GigabitEthernet0/0/0/3
   network point-to-point
  !
 !
!
router bgp 23
 bgp cluster-id 23.0.3.3
 address-family vpnv4 unicast
 !
 neighbor-group CLIENTS
  remote-as 23
  update-source Loopback0
  address-family vpnv4 unicast
   route-reflector-client
  !
 !
 neighbor 23.0.1.1
  use neighbor-group CLIENTS
 !
 neighbor 23.0.2.2
  use neighbor-group CLIENTS
 !
 neighbor 23.0.4.4
  use neighbor-group CLIENTS
 !
 neighbor 23.0.5.5
  remote-as 23
  update-source Loopback0
  address-family vpnv4 unicast
  !
 !
!
mpls ldp
 interface GigabitEthernet0/0/0/0
 !
 interface GigabitEthernet0/0/0/1
 !
 interface GigabitEthernet0/0/0/2
 !
 interface GigabitEthernet0/0/0/3
 !
!
multicast-routing
 address-family ipv4
  interface all enable
 !
!
router pim
 address-family ipv4
  bsr candidate-bsr 23.0.3.3 hash-mask-len 30 priority 1
  bsr candidate-rp 23.0.3.3 priority 192 interval 60
 !
!


R4: 


!
logging console debugging
vrf CUST_A
 address-family ipv4 unicast
  import route-target
   100:100
  !
  export route-target
   100:100
  !
 !
!
!
interface Loopback0
 ipv4 address 23.0.4.4 255.255.255.255
!
!
interface GigabitEthernet0/0/0/0
 ipv4 address 23.0.45.4 255.255.255.0
!
interface GigabitEthernet0/0/0/1
 ipv4 address 23.0.34.4 255.255.255.0
!
interface GigabitEthernet0/0/0/2
 ipv4 address 23.0.14.4 255.255.255.0
!
interface GigabitEthernet0/0/0/3
 ipv4 address 23.0.24.4 255.255.255.0
!
interface GigabitEthernet0/0/0/4
 vrf CUST_A
 ipv4 address 23.0.48.4 255.255.255.0
!
!
router static
 vrf CUST_A
  address-family ipv4 unicast
   10.0.8.0/24 23.0.48.8
  !
 !
!
router ospf 1
 router-id 23.0.4.4
 area 0
  interface Loopback0
  !
  interface GigabitEthernet0/0/0/0
   network point-to-point
  !
  interface GigabitEthernet0/0/0/1
   network point-to-point
  !
  interface GigabitEthernet0/0/0/2
   network point-to-point
  !
  interface GigabitEthernet0/0/0/3
   network point-to-point
  !
 !
!
router bgp 23
 address-family vpnv4 unicast
 !
 neighbor 23.0.3.3
  remote-as 23
  update-source Loopback0
  address-family vpnv4 unicast
  !
 !
 neighbor 23.0.5.5
  remote-as 23
  update-source Loopback0
  address-family vpnv4 unicast
  !
 !
 vrf CUST_A
  rd 100:100
  address-family ipv4 unicast
   redistribute connected
   redistribute static
  !
 !
!
mpls ldp
 interface GigabitEthernet0/0/0/0
 !
 interface GigabitEthernet0/0/0/1
 !
 interface GigabitEthernet0/0/0/2
 !
 interface GigabitEthernet0/0/0/3
 !
!
multicast-routing
 address-family ipv4
  mdt source Loopback0
  interface all enable
 !
 vrf CUST_A
  address-family ipv4
   interface all enable
   mdt default ipv4 239.0.1.1
  !
 !
!


R5: 


!
ip multicast-routing
!
!
interface Loopback0
 ip address 23.0.5.5 255.255.255.255
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface Ethernet0/0
 ip address 23.0.35.5 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface Ethernet0/1
 ip address 23.0.15.5 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface Ethernet0/2
 ip address 23.0.25.5 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
interface Ethernet0/3
 ip address 23.0.45.5 255.255.255.0
 ip pim sparse-mode
 ip ospf network point-to-point
 ip ospf 1 area 0
!
!
router ospf 1
 mpls ldp autoconfig
 router-id 23.0.5.5
!
router bgp 23
 bgp cluster-id 23.0.5.5
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 neighbor CLIENTS peer-group
 neighbor CLIENTS remote-as 23
 neighbor CLIENTS update-source Loopback0
 neighbor 23.0.1.1 peer-group CLIENTS
 neighbor 23.0.2.2 peer-group CLIENTS
 neighbor 23.0.3.3 remote-as 23
 neighbor 23.0.3.3 update-source Loopback0
 neighbor 23.0.4.4 peer-group CLIENTS
 !
 address-family ipv4
 exit-address-family
 !
 address-family vpnv4
  neighbor CLIENTS send-community both
  neighbor CLIENTS route-reflector-client
  neighbor 23.0.1.1 activate
  neighbor 23.0.2.2 activate
  neighbor 23.0.3.3 activate
  neighbor 23.0.3.3 send-community both
  neighbor 23.0.4.4 activate
 exit-address-family
!

R6:

!
ip multicast-routing
!
!
interface Loopback0
 ip address 10.0.6.6 255.255.255.255
 ip pim sparse-mode
!
interface Ethernet0/0
 ip address 23.0.16.6 255.255.255.0
 ip pim sparse-mode
!
ip pim bsr-candidate Loopback0 0
ip pim rp-candidate Loopback0
ip route 0.0.0.0 0.0.0.0 23.0.16.1
!

R7:


ip multicast-routing
!
interface Loopback0
 ip address 10.0.7.7 255.255.255.255
 ip pim sparse-mode
 ip igmp join-group 239.10.10.10
!
interface Ethernet0/0
 ip address 23.0.27.7 255.255.255.0
 ip pim sparse-mode
!
ip route 0.0.0.0 0.0.0.0 23.0.27.2


R8:


ip multicast-routing
!
!
interface Loopback0
 ip address 10.0.8.8 255.255.255.255
 ip pim sparse-mode
 ip igmp join-group 239.10.10.10
!
interface Ethernet0/0
 ip address 23.0.48.8 255.255.255.0
 ip pim sparse-mode
!
ip route 0.0.0.0 0.0.0.0 23.0.48.4
!



Verification:


R1#sh ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
23.0.15.5         Ethernet0/0              05:20:27/00:01:33 v2    1 / DR S P G
23.0.13.3         Ethernet0/1              05:16:59/00:01:26 v2    1 / DR G
23.0.12.2         Ethernet0/2              04:54:07/00:01:20 v2    1 / DR S P G
23.0.14.4         Ethernet0/3              05:16:27/00:01:21 v2    1 / DR G

R1#sh ip pim rp mapping
PIM Group-to-RP Mappings

Group(s) 224.0.0.0/4
  RP 23.0.5.5 (?), v2
    Info source: 23.0.3.3 (?), via bootstrap, priority 0, holdtime 150
         Uptime: 04:43:23, expires: 00:02:06
  RP 23.0.3.3 (?), v2
    Info source: 23.0.3.3 (?), via bootstrap, priority 192, holdtime 150
         Uptime: 04:46:38, expires: 00:02:07


R1#        show ip pim vrf CUST_A neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
23.0.4.4          Tunnel1                  04:37:13/00:01:23 v2    1 / DR G
23.0.2.2          Tunnel1                  04:51:34/00:01:37 v2    1 / S P G
23.0.16.6         Ethernet1/0              05:03:06/00:01:44 v2    1 / DR S P G

R1#sh ip pim vrf CUST_A rp mapping
PIM Group-to-RP Mappings

Group(s) 224.0.0.0/4
  RP 10.0.6.6 (?), v2
    Info source: 10.0.6.6 (?), via bootstrap, priority 0, holdtime 150
         Uptime: 04:42:23, expires: 00:01:51


R2#           sh ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
23.0.25.5         Ethernet0/0              04:55:29/00:01:21 v2    1 / DR S P G
23.0.23.3         Ethernet0/1              04:55:56/00:01:37 v2    1 / DR G
23.0.12.1         Ethernet0/2              04:55:29/00:01:34 v2    1 / S P G
23.0.24.4         Ethernet0/3              04:55:58/00:01:26 v2    1 / DR G


R2#sh ip pim vrf CUST_A neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
23.0.27.7         Ethernet1/0              04:55:34/00:01:36 v2    1 / DR S P G
23.0.4.4          Tunnel0                  04:39:43/00:01:24 v2    1 / DR G
23.0.1.1          Tunnel0                  04:49:38/00:01:44 v2    1 / S P G

RP/0/0/CPU0:ios#            show pim interface
Mon Jan 18 18:02:44.871 UTC

PIM interfaces in VRF default
Address               Interface                     PIM  Nbr   Hello  DR    DR
                                                         Count Intvl  Prior

23.0.4.4              Loopback0                     on   1     30     1     this system
23.0.45.4             GigabitEthernet0/0/0/0        on   2     30     1     23.0.45.5
23.0.34.4             GigabitEthernet0/0/0/1        on   2     30     1     this system
23.0.14.4             GigabitEthernet0/0/0/2        on   2     30     1     this system
23.0.24.4             GigabitEthernet0/0/0/3        on   2     30     1     this system

RP/0/0/CPU0:ios#show pim rp mapping
Mon Jan 18 18:02:49.151 UTC
PIM Group-to-RP Mappings
Group(s) 224.0.0.0/4
  RP 23.0.5.5 (?), v2
    Info source: 23.0.34.3 (?), elected via bsr, priority 0, holdtime 150
      Uptime: 04:53:16, expires: 00:01:49
Group(s) 224.0.0.0/4
  RP 23.0.3.3 (?), v2
    Info source: 23.0.34.3 (?), elected via bsr, priority 192, holdtime 150
      Uptime: 04:51:59, expires: 00:01:49


RP/0/0/CPU0:ios#show pim vrf CUST_A interface
Mon Jan 18 18:02:55.390 UTC

PIM interfaces in VRF CUST_A
Address               Interface                     PIM  Nbr   Hello  DR    DR
                                                         Count Intvl  Prior

23.0.4.4              mdtCUST/A                     on   3     30     1     this system
23.0.48.4             GigabitEthernet0/0/0/4        on   2     30     1     23.0.48.8


RP/0/0/CPU0:ios#show pim neighbor
Mon Jan 18 18:02:59.230 UTC

PIM neighbors in VRF default
Flag: B - Bidir capable, P - Proxy capable, DR - Designated Router,
      E - ECMP Redirect capable
      * indicates the neighbor created for this router

Neighbor Address             Interface              Uptime    Expires  DR pri   Flags

23.0.45.4*                   GigabitEthernet0/0/0/0 05:22:05  00:01:34 1      B E
23.0.45.5                    GigabitEthernet0/0/0/0 05:21:59  00:01:42 1 (DR) P
23.0.34.3                    GigabitEthernet0/0/0/1 05:22:00  00:01:19 1      B
23.0.34.4*                   GigabitEthernet0/0/0/1 05:22:05  00:01:23 1 (DR) B E
23.0.14.1                    GigabitEthernet0/0/0/2 05:22:02  00:01:21 1      P
23.0.14.4*                   GigabitEthernet0/0/0/2 05:22:05  00:01:18 1 (DR) B E
23.0.24.2                    GigabitEthernet0/0/0/3 05:22:00  00:01:17 1      P
23.0.24.4*                   GigabitEthernet0/0/0/3 05:22:05  00:01:44 1 (DR) B E
23.0.4.4*                    Loopback0              05:22:05  00:01:24 1 (DR) B E

PIM neighbors in VRF CUST_A
Flag: B - Bidir capable, P - Proxy capable, DR - Designated Router,
      E - ECMP Redirect capable
      * indicates the neighbor created for this router

Neighbor Address             Interface              Uptime    Expires  DR pri   Flags

23.0.48.4*                   GigabitEthernet0/0/0/4 04:44:57  00:01:32 1      B E
23.0.48.8                    GigabitEthernet0/0/0/4 04:44:54  00:01:18 1 (DR) P
23.0.1.1                     mdtCUST/A              04:43:39  00:01:18 1      P
23.0.2.2                     mdtCUST/A              04:43:35  00:01:40 1      P
23.0.4.4*                    mdtCUST/A              04:43:40  00:01:33 1 (DR)


RP/0/0/CPU0:ios#show pim vrf CUST_A rp mapping
Mon Jan 18 18:03:20.298 UTC
PIM Group-to-RP Mappings
Group(s) 224.0.0.0/4
  RP 10.0.6.6 (?), v2
    Info source: 23.0.1.1 (?), elected via bsr, priority 0, holdtime 150
      Uptime: 04:43:30, expires: 00:01:48


R6#sh ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable, G - GenID Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
23.0.16.1         Ethernet0/0              05:14:46/00:01:25 v2    1 / S P G


R6#ping 239.10.10.10 source lo0 repeat 4
Type escape sequence to abort.
Sending 4, 100-byte ICMP Echos to 239.10.10.10, timeout is 2 seconds:
Packet sent with a source address of 10.0.6.6

Reply to request 0 from 10.0.7.7, 6 ms
Reply to request 0 from 10.0.8.8, 19 ms
Reply to request 0 from 10.0.8.8, 16 ms
Reply to request 0 from 10.0.7.7, 12 ms
Reply to request 1 from 10.0.7.7, 2 ms
Reply to request 1 from 10.0.8.8, 6 ms
Reply to request 1 from 10.0.8.8, 6 ms
Reply to request 1 from 10.0.7.7, 2 ms
Reply to request 2 from 10.0.7.7, 2 ms
Reply to request 2 from 10.0.8.8, 6 ms
Reply to request 2 from 10.0.8.8, 5 ms
Reply to request 2 from 10.0.7.7, 3 ms
Reply to request 3 from 10.0.7.7, 3 ms
Reply to request 3 from 10.0.8.8, 7 ms
Reply to request 3 from 10.0.8.8, 6 ms
Reply to request 3 from 10.0.7.7, 3 ms




This post first appeared on CCIE Service Provider Workbook, please read the originial post: here

Share the post

L3VPN task 11. Simple MVPN.

×

Subscribe to Ccie Service Provider Workbook

Get updates delivered right to your inbox!

Thank you for your subscription

×