Get Even More Visitors To Your Blog, Upgrade To A Business Listing >>

L3VPN task 10. CSC, supporting MPLS VPN carrier.

Topology:



Use configuration from L3VPN task #9 as initial configuration for this task.
Routers R9 and R10 are added to the topology. 

Requirements: 

AS22 will be providing L3VPN MPLS service to Customer A, represented by routers R9 and R10. 
Use networks 22.0.19/24 and 22.0.107/24 for links between AS22 and Customer A CE routers. 

1. Customer A is not running any IGP. Use static routes to provide connectivity between sites R9 and     R10. 
2. Update the network configuration to provide the service to Customer A. 

Solution:

Highlight the text below to reveal the solution.

This task requires understanding of CSC configuration for Carrier that provides MPLS VPN services. 
The difference from the previous task, is that Customer Carrier runs IGP and LDP, and Customer Carrier PE routers exchange VPNv4 BGP address-family prefixes directly or via route-reflectors. 

R1:


 !
vrf definition CUST_A
 rd 100:100
 route-target export 100:100
 route-target import 100:100
 !
 address-family ipv4
 exit-address-family
!
!
interface Ethernet1/0
 vrf forwarding CUST_A
 ip address 22.0.19.1 255.255.255.0
!
router ospf 1
 mpls ldp autoconfig
 router-id 22.0.1.1
 network 0.0.0.0 255.255.255.255 area 0
!
router bgp 22
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 neighbor 22.0.2.2 remote-as 22
 neighbor 22.0.2.2 update-source Loopback0
 neighbor 22.0.7.7 remote-as 22
 neighbor 22.0.7.7 update-source Loopback0
 !
 address-family ipv4
  neighbor 22.0.2.2 activate
  neighbor 22.0.7.7 activate
 exit-address-family
 !
 address-family vpnv4
  neighbor 22.0.7.7 activate
  neighbor 22.0.7.7 send-community both
 exit-address-family
 !
 address-family ipv4 vrf CUST_A
  redistribute connected
  redistribute static
 exit-address-family
!
!
ip route vrf CUST_A 10.10.9.0 255.255.255.0 22.0.19.9
!
!


R2:


!
router ospf 1
 mpls ldp autoconfig
 router-id 22.0.2.2
 redistribute bgp 22 subnets
 passive-interface Ethernet1/0
 network 0.0.0.0 255.255.255.255 area 0
!

R4:

!
mpls ldp
 interface GigabitEthernet0/0/0/0
 !
!

R7:


!
vrf definition CUST_A
 rd 100:100
 route-target export 100:100
 route-target import 100:100
 !
 address-family ipv4
 exit-address-family
!
interface Ethernet1/1
 vrf forwarding CUST_A
 ip address 22.0.107.7 255.255.255.0
!
!
router ospf 1
 mpls ldp autoconfig
 router-id 22.0.7.7
 passive-interface Ethernet1/0
 network 0.0.0.0 255.255.255.255 area 0
!
router bgp 22
 bgp router-id 22.0.7.7
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 neighbor 8.0.78.8 remote-as 8
 neighbor 22.0.1.1 remote-as 22
 neighbor 22.0.1.1 update-source Loopback0
 neighbor 22.0.2.2 remote-as 22
 neighbor 22.0.2.2 update-source Loopback0
 neighbor 22.0.4.4 remote-as 22
 neighbor 22.0.4.4 update-source Loopback0
 !
 address-family ipv4
  network 22.0.0.0 mask 255.255.0.0
  neighbor 8.0.78.8 activate
  neighbor 22.0.1.1 activate
  neighbor 22.0.2.2 activate
  neighbor 22.0.2.2 next-hop-self
  neighbor 22.0.4.4 activate
  neighbor 22.0.4.4 next-hop-self
 exit-address-family
 !
 address-family vpnv4
  neighbor 22.0.1.1 activate
  neighbor 22.0.1.1 send-community both
 exit-address-family
 !
 address-family ipv4 vrf CUST_A
  redistribute connected
  redistribute static
 exit-address-family
!
ip route vrf CUST_A 10.10.10.0 255.255.255.0 22.0.107.10
!

R9:


!
interface Loopback0
 ip address 10.10.9.9 255.255.255.255
!
interface Ethernet0/0
 ip address 22.0.19.9 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 22.0.19.1

R10: 


!
interface Loopback0
 ip address 10.10.10.10 255.255.255.255
!
interface Ethernet0/0
 ip address 22.0.107.10 255.255.255.0
!
ip route 0.0.0.0 0.0.0.0 22.0.107.7
!

Verification:

R9#           traceroute 10.10.10.10 source 10.10.9.9
Type escape sequence to abort.
Tracing the route to 10.10.10.10
VRF info: (vrf in name/id, vrf out name/id)
  1 22.0.19.1 1 msec 0 msec 0 msec
  2 22.0.12.2 [MPLS: Labels 19/22 Exp 0] 7 msec 6 msec 6 msec
  3 21.0.23.3 [MPLS: Labels 24011/22 Exp 0] 9 msec 7 msec 7 msec
  4 21.0.35.5 [MPLS: Labels 16/19/22 Exp 0] 6 msec 8 msec 7 msec
  5 21.0.56.6 [MPLS: Labels 19/22 Exp 0] 8 msec 8 msec 8 msec
  6 21.0.46.4 [MPLS: Labels 24007/22 Exp 0] 6 msec 8 msec 7 msec
  7 22.0.107.7 [MPLS: Label 22 Exp 0] 7 msec 9 msec 7 msec
  8 22.0.107.10 7 msec 7 msec 8 msec


R10#      traceroute 10.10.9.9 source 10.10.10.10
Type escape sequence to abort.
Tracing the route to 10.10.9.9
VRF info: (vrf in name/id, vrf out name/id)
  1 22.0.107.7 1 msec 0 msec 0 msec
  2 22.0.47.4 [MPLS: Labels 24003/23 Exp 0] 7 msec 6 msec 6 msec
  3 21.0.46.6 [MPLS: Labels 28/23 Exp 0] 6 msec 6 msec 8 msec
  4 21.0.56.5 [MPLS: Labels 17/24006/23 Exp 0] 6 msec 7 msec 7 msec
  5 21.0.35.3 [MPLS: Labels 24006/23 Exp 0] 7 msec 7 msec 7 msec
  6 21.0.23.2 [MPLS: Labels 24/23 Exp 0] 7 msec 7 msec 8 msec
  7 22.0.19.1 [MPLS: Label 23 Exp 0] 6 msec 7 msec 7 msec
  8 22.0.19.9 9 msec 8 msec 7 msec


R10#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 22.0.107.7 to network 0.0.0.0

S*    0.0.0.0/0 [1/0] via 22.0.107.7
      10.0.0.0/32 is subnetted, 1 subnets
C        10.10.10.10 is directly connected, Loopback0
      22.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        22.0.107.0/24 is directly connected, Ethernet0/0
L        22.0.107.10/32 is directly connected, Ethernet0/0


R1#sh ip route vrf CUST_A

Routing Table: CUST_A
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      10.0.0.0/24 is subnetted, 2 subnets
S        10.10.9.0 [1/0] via 22.0.19.9
B        10.10.10.0 [200/0] via 22.0.7.7, 00:46:52
      22.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C        22.0.19.0/24 is directly connected, Ethernet1/0
L        22.0.19.1/32 is directly connected, Ethernet1/0
B        22.0.107.0/24 [200/0] via 22.0.7.7, 00:49:17


R1#show mpls forwarding-table
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
16         Pop Label  21.0.23.0/24     0             Et0/0      22.0.12.2
17         Pop Label  22.0.2.2/32      0             Et0/0      22.0.12.2
18         18         22.0.4.4/32      0             Et0/0      22.0.12.2
19         19         22.0.7.7/32      0             Et0/0      22.0.12.2
20         16         22.0.47.0/24     0             Et0/0      22.0.12.2
22         No Label   22.0.19.0/24[V]  3012          aggregate/CUST_A
23         No Label   10.10.9.0/24[V]  6426          Et1/0      22.0.19.9

R1#sh ip cef vrf CUST_A 10.10.10.10
10.10.10.0/24
  nexthop 22.0.12.2 Ethernet0/0 label 19 22
R1#sh ip cef vrf CUST_A 10.10.10.10  det
R1#sh ip cef vrf CUST_A 10.10.10.10  detail
10.10.10.0/24, epoch 0, flags rib defined all labels
  recursive via 22.0.7.7 label 22
    nexthop 22.0.12.2 Ethernet0/0 label 19


R2#  show mpls forwarding-table
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
16         24012      22.0.47.0/24     0             Et1/0      21.0.23.3
17         No Label   11.0.0.0/8       0             Et1/0      21.0.23.3
18         24010      22.0.4.4/32      0             Et1/0      21.0.23.3
19         24011      22.0.7.7/32      30754         Et1/0      21.0.23.3
20         No Label   33.0.0.0/8       0             Et1/0      21.0.23.3
21         No Label   8.0.0.0/16       0             Et1/0      21.0.23.3
22         Pop Label  21.0.23.3/32     0             Et1/0      21.0.23.3
23         No Label   55.0.0.0/8       0             Et1/0      21.0.23.3
24         Pop Label  22.0.1.1/32      33580         Et0/0      22.0.12.1
30         No Label   22.0.0.0/16      0             Et1/0      21.0.23.3

R7#           show mpls forwarding-table
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
16         24003      22.0.1.1/32      0             Et0/0      22.0.47.4
17         24004      22.0.2.2/32      0             Et0/0      22.0.47.4
18         Pop Label  22.0.4.4/32      0             Et0/0      22.0.47.4
19         24005      22.0.12.0/24     0             Et0/0      22.0.47.4
21         No Label   22.0.107.0/24[V] 3102          aggregate/CUST_A
22         No Label   10.10.10.0/24[V] 10614         Et1/1      22.0.107.10




This post first appeared on CCIE Service Provider Workbook, please read the originial post: here

Share the post

L3VPN task 10. CSC, supporting MPLS VPN carrier.

×

Subscribe to Ccie Service Provider Workbook

Get updates delivered right to your inbox!

Thank you for your subscription

×