Get Even More Visitors To Your Blog, Upgrade To A Business Listing >>

L3VPN task #9. CSC, supporting an ISP carrier.

Topology:



Start with initial configuration - loopback0 interfaces and links between routers according to above topology.

Requirements:

1. Configure Service Provider A internal network according to topology:
           1.1 Configure loopback0 interfaces and links between routers.
           1.2 IGP - only create level-2 databases, route metric should be represented by 24bits, disable                              CSNP flooding
           1.3 iBGP - only exchange VPNv4 address-family, minimize the required number of iBGP                                      peering sessions
           1.4 MPLS - use minimal amount of commands to enable MPLS and LDP

2. Configure Service Provider B internal network according to topology: 
           2.1 Configure loopback0 interfaces and links between routers. 
           2.2 IGP - use network type that allows faster convergence. minimize the number of commands                            required to enable OSPF on interfaces. 
           2.3 eBGP - configure R7 to establish eBGP peering with R9, and advertise prefix 22.0/16. 

3. Configure Service Provider C: 
           3.1 Create loopback0 interface
           3.2 Create interfaces loopback11, 33 and 55 with addressess 11.11.11.11/32, 33.33.33.33/32 &                  55.55.55.55/32. 
           3.3 eBGP - configure eBGP session with R7 and advertise networks 8.0/24, 11/8, 33/8 & 55/8.

4. Configure Carrier supporting Carrier solution:
                use networks 21.0.23/24 and 21.0.46/24 for links  between AS21 and AS22. 
          4.1 AS22 should provide connectivity between the two AS21 sites 1 & 2.
          4.2 All routers of AS21 should be able to access the Internet via AS8.
          4.3 Use eBGP protocol for routing between CSC-CE and CSC-PE devices.
          4.4 Assume that AS22 is an ISP, and all routers of AS22 carry full Internet routing table.                           Configure the AS22 and AS21 accordingly.
          4.5 R1 is only allowed to have BGP peering with R2.
         



Solution:

Highlight the text below to reveal the solution.


This solution requires understanding of L3VPN Carrier-supporting-carrier configuration
For this task, eBGP is used for  CSC-CE to CSC-PE routes exchange, which is the more common case, and the only configuration supported by IOX-XR. 
This task also contains some requirements related to OSPF and ISIS configuration. 

Requirement #1 - disable default ipv4 unicast address family. configure R5 as route-reflector and R3,                              R6 as clients, set is-type to level-2-only to disable level-1 database, use wide                                        metric (24 bit ), use "mpls ldp autoconfig" to enable LDP on all ISIS interfaces, use                              point-to-point interfaces.

Requirement #2 - use network type point-to-point to speed up convergence ( vs the default broadcast                                network type). on IOS routers, use "network 0.0.0.0 255.255.255.255 area 0"                                        command, instead of configuring OSPF on individual interfaces.  


Requirement #4 - on CSC-CE to CSC-PE eBGP sessions apply filter to only allow prefixes from                                       22.0/16 range into the CSC-PE VRF for AS22. otherwise CSC-PE routers will                                     receive the full BGP table view from the CSC-CE routers, which must be avoided. 
                              Since R1 is only allowed to peer with R2, configure R2 as route reflector, and R1                                 as route-reflector client. 


Note: IOS-XR only allows eBGP + labels for CSC-CE- CSC-PE protocol in CSC solution. For IOS routers, another option is to exchange routes using IGP and enable LDP on the CSC-CE - CSC-PE link. 

R1: 


!
interface Loopback0
 ip address 22.0.1.1 255.255.255.255
 ip ospf network point-to-point
!
interface Ethernet0/0
 ip address 22.0.12.1 255.255.255.0
 ip ospf network point-to-point
!
!
router ospf 1
 router-id 22.0.1.1
 network 0.0.0.0 255.255.255.255 area 0
!
router bgp 22
 bgp log-neighbor-changes
 neighbor 22.0.2.2 remote-as 22
 neighbor 22.0.2.2 update-source Loopback0
!


R2:

!
interface Loopback0
 ip address 22.0.2.2 255.255.255.255
 ip ospf network point-to-point
!
interface Ethernet0/0
 ip address 22.0.12.2 255.255.255.0
 ip ospf network point-to-point
!
!
interface Ethernet1/0
 ip address 21.0.23.2 255.255.255.0
 mpls bgp forwarding
!
!
router ospf 1
 router-id 22.0.2.2
 redistribute bgp 22 subnets
 passive-interface Ethernet1/0
 network 0.0.0.0 255.255.255.255 area 0
!
router bgp 22
 bgp log-neighbor-changes
 neighbor 21.0.23.3 remote-as 21
 neighbor 22.0.1.1 remote-as 22
 neighbor 22.0.1.1 update-source Loopback0
 neighbor 22.0.7.7 remote-as 22
 neighbor 22.0.7.7 update-source Loopback0
 !
 address-family ipv4
  redistribute ospf 1
  neighbor 21.0.23.3 activate
  neighbor 21.0.23.3 send-community both
  neighbor 21.0.23.3 allowas-in 1
  neighbor 21.0.23.3 send-label
  neighbor 22.0.1.1 activate
  neighbor 22.0.1.1 route-reflector-client
  neighbor 22.0.7.7 activate
 exit-address-family
!

R3:


!
vrf AS22
 address-family ipv4 unicast
  import route-target
   22:22
  !
  export route-target
   22:22
  !
 !
!
interface Loopback0
 ipv4 address 21.0.3.3 255.255.255.255
!
!
interface GigabitEthernet0/0/0/0
 vrf AS22
 ipv4 address 21.0.23.3 255.255.255.0
!
interface GigabitEthernet0/0/0/1
 ipv4 address 21.0.35.3 255.255.255.0
!
!
prefix-set AS22
  22.0.0.0/16 le 32
end-set
!
route-policy ANY
  pass
end-policy
!
route-policy AS22_IN
  if destination in AS22 then
    pass
  endif
end-policy
!
router static
 vrf AS22
  address-family ipv4 unicast
   21.0.23.2/32 GigabitEthernet0/0/0/0
  !
 !
!
!
router isis AS21
 is-type level-2-only
 net 49.0021.0000.0000.0003.00
 address-family ipv4 unicast
  metric-style wide
  mpls ldp auto-config
 !
 interface Loopback0
  address-family ipv4 unicast
  !
 !
 interface GigabitEthernet0/0/0/1
  point-to-point
  address-family ipv4 unicast
  !
 !
!
router bgp 21
 address-family ipv4 unicast
 !
 address-family vpnv4 unicast
 !
 neighbor 21.0.5.5
  remote-as 21
  update-source Loopback0
  address-family vpnv4 unicast
  !
 !
 vrf AS22
  rd 22:22
  address-family ipv4 unicast
   as-path-loopcheck out disable
   allocate-label all
  !
  neighbor 21.0.23.2
   remote-as 22
   address-family ipv4 labeled-unicast
    route-policy AS22_IN in
    route-policy ANY out
   !
  !
 !
!
mpls ldp
!

R4:

!
interface Loopback0
 ipv4 address 22.0.4.4 255.255.255.255
!
!
interface GigabitEthernet0/0/0/0
 ipv4 address 22.0.47.4 255.255.255.0
!
interface GigabitEthernet0/0/0/1
 ipv4 address 21.0.46.4 255.255.255.0
!
!
route-policy ANY
  pass
end-policy
!
router static
 address-family ipv4 unicast
  21.0.46.6/32 GigabitEthernet0/0/0/1
 !
!
router ospf 1
 router-id 22.0.4.4
 redistribute bgp 22
 area 0
  interface Loopback0
  !
  interface GigabitEthernet0/0/0/0
   network point-to-point
  !
 !
!
router bgp 22
 address-family ipv4 unicast
  redistribute ospf 1
  allocate-label all
 !
 neighbor 22.0.7.7
  remote-as 22
  update-source Loopback0
  address-family ipv4 unicast
  !
 !
 neighbor 21.0.46.6
  remote-as 21
  address-family ipv4 labeled-unicast
   route-policy ANY in
   allowas-in 1
   route-policy ANY out
  !
 !
!

R5: 


!
interface Loopback0
 ip address 21.0.5.5 255.255.255.255
 ip router isis AS21
 ip ospf network point-to-point
!
interface Ethernet0/0
 ip address 21.0.35.5 255.255.255.0
 ip router isis AS21
 isis network point-to-point
!
interface Ethernet0/1
 ip address 21.0.56.5 255.255.255.0
 ip router isis AS21
 isis network point-to-point
!
!
router isis AS21
 mpls ldp autoconfig
 net 49.0021.0000.0000.0005.00
 is-type level-2-only
 metric-style wide
!
router bgp 21
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 neighbor CLIENTS peer-group
 neighbor CLIENTS remote-as 21
 neighbor CLIENTS update-source Loopback0
 neighbor 21.0.3.3 peer-group CLIENTS
 neighbor 21.0.6.6 peer-group CLIENTS
 !
 address-family ipv4
 exit-address-family
 !
 address-family vpnv4
  neighbor CLIENTS send-community both
  neighbor CLIENTS route-reflector-client
  neighbor 21.0.3.3 activate
  neighbor 21.0.6.6 activate
 exit-address-family
!

R6:

!
vrf definition AS22
 rd 22:22
 route-target export 22:22
 route-target import 22:22
 !
 address-family ipv4
 exit-address-family
!
!
!
interface Loopback0
 ip address 21.0.6.6 255.255.255.255
 ip router isis AS21
 ip ospf network point-to-point
!
interface Ethernet0/0
 ip address 21.0.56.6 255.255.255.0
 ip router isis AS21
 isis network point-to-point
!
!
interface Ethernet1/0
 vrf forwarding AS22
 ip address 21.0.46.6 255.255.255.0
 mpls bgp forwarding
!
!
router isis AS21
 mpls ldp autoconfig
 net 49.0021.0000.0000.0006.00
 is-type level-2-only
 metric-style wide
!
router bgp 21
 bgp log-neighbor-changes
 no bgp default ipv4-unicast
 neighbor 21.0.5.5 remote-as 21
 neighbor 21.0.5.5 update-source Loopback0
 !
 address-family ipv4
 exit-address-family
 !
 address-family vpnv4
  neighbor 21.0.5.5 activate
  neighbor 21.0.5.5 send-community both
 exit-address-family
 !
 address-family ipv4 vrf AS22
  neighbor 21.0.46.4 remote-as 22
  neighbor 21.0.46.4 activate
  neighbor 21.0.46.4 send-community both
  neighbor 21.0.46.4 route-map AS22_IN in
  neighbor 21.0.46.4 send-label
 exit-address-family
!
!
ip prefix-list AS22 seq 5 permit 22.0.0.0/16 le 32
!
route-map AS22_IN permit 10
 match ip address prefix-list AS22
!

R7: 

!
interface Loopback0
 ip address 22.0.7.7 255.255.255.255
 ip ospf network point-to-point
!
interface Ethernet0/0
 ip address 22.0.47.7 255.255.255.0
 ip ospf network point-to-point
!
!
interface Ethernet1/0
 ip address 8.0.78.7 255.255.255.0
!
!
router ospf 1
 router-id 22.0.7.7
 passive-interface Ethernet1/0
 network 0.0.0.0 255.255.255.255 area 0
!
router bgp 22
 bgp router-id 22.0.7.7
 bgp log-neighbor-changes
 network 22.0.0.0 mask 255.255.0.0
 neighbor 8.0.78.8 remote-as 8
 neighbor 22.0.2.2 remote-as 22
 neighbor 22.0.2.2 update-source Loopback0
 neighbor 22.0.2.2 next-hop-self
 neighbor 22.0.4.4 remote-as 22
 neighbor 22.0.4.4 update-source Loopback0
 neighbor 22.0.4.4 next-hop-self
!
ip route 22.0.0.0 255.255.0.0 Null0
!

R8:


!
interface Loopback0
 ip address 8.0.8.8 255.255.255.255
!
interface Loopback11
 ip address 11.11.11.11 255.255.255.255
!
interface Loopback33
 ip address 33.33.33.33 255.255.255.255
!
interface Loopback55
 ip address 55.55.55.55 255.255.255.255
!
interface Ethernet0/0
 ip address 8.0.78.8 255.255.255.0
!
!
router bgp 8
 bgp log-neighbor-changes
 network 8.0.0.0 mask 255.255.0.0
 network 11.0.0.0
 network 33.0.0.0
 network 55.0.0.0
 neighbor 8.0.78.7 remote-as 22
!
!
no ip http server
no ip http secure-server
ip route 8.0.0.0 255.255.0.0 Null0
ip route 11.0.0.0 255.0.0.0 Null0
ip route 22.0.0.0 255.0.0.0 Null0
ip route 33.0.0.0 255.0.0.0 Null0
ip route 55.0.0.0 255.0.0.0 Null0
!


Verification:


R1#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      8.0.0.0/16 is subnetted, 1 subnets
B        8.0.0.0 [200/0] via 22.0.7.7, 00:27:39
B     11.0.0.0/8 [200/0] via 22.0.7.7, 00:27:39
      21.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
O        21.0.23.0/24 [110/20] via 22.0.12.2, 03:17:32, Ethernet0/0
B        21.0.23.3/32 [200/0] via 22.0.2.2, 00:28:59
      22.0.0.0/8 is variably subnetted, 8 subnets, 3 masks
B        22.0.0.0/16 [200/0] via 22.0.7.7, 00:28:59
C        22.0.1.1/32 is directly connected, Loopback0
O        22.0.2.2/32 [110/11] via 22.0.12.2, 03:29:31, Ethernet0/0
O E2     22.0.4.4/32 [110/1] via 22.0.12.2, 02:26:38, Ethernet0/0
O E2     22.0.7.7/32 [110/1] via 22.0.12.2, 02:26:38, Ethernet0/0
C        22.0.12.0/24 is directly connected, Ethernet0/0
L        22.0.12.1/32 is directly connected, Ethernet0/0
O E2     22.0.47.0/24 [110/1] via 22.0.12.2, 02:26:38, Ethernet0/0
B     33.0.0.0/8 [200/0] via 22.0.7.7, 00:27:39
B     55.0.0.0/8 [200/0] via 22.0.7.7, 00:26:09


R1#   traceroute 55.55.55.55 source lo0
Type escape sequence to abort.
Tracing the route to 55.55.55.55
VRF info: (vrf in name/id, vrf out name/id)
  1 22.0.12.2 1 msec 0 msec 5 msec
  2 21.0.23.3 [MPLS: Label 24011 Exp 0] 7 msec 7 msec 8 msec
  3 21.0.35.5 [MPLS: Labels 16/19 Exp 0] 6 msec 7 msec 7 msec
  4 21.0.46.6 [MPLS: Label 19 Exp 0] 7 msec 7 msec 6 msec
  5 21.0.46.4 [MPLS: Label 24007 Exp 0] 6 msec 7 msec 8 msec
  6 22.0.47.7 [AS 22] 7 msec 7 msec 8 msec
  7 8.0.78.8 [AS 8] 7 msec 7 msec 9 msec


R2#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      8.0.0.0/16 is subnetted, 1 subnets
B        8.0.0.0 [200/0] via 22.0.7.7, 00:34:43
B     11.0.0.0/8 [200/0] via 22.0.7.7, 00:34:43
      21.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C        21.0.23.0/24 is directly connected, Ethernet1/0
L        21.0.23.2/32 is directly connected, Ethernet1/0
C        21.0.23.3/32 is directly connected, Ethernet1/0
      22.0.0.0/8 is variably subnetted, 8 subnets, 3 masks
B        22.0.0.0/16 [200/0] via 22.0.7.7, 00:40:51
O        22.0.1.1/32 [110/11] via 22.0.12.1, 03:17:50, Ethernet0/0
C        22.0.2.2/32 is directly connected, Loopback0
B        22.0.4.4/32 [20/0] via 21.0.23.3, 02:33:42
B        22.0.7.7/32 [20/0] via 21.0.23.3, 02:33:42
C        22.0.12.0/24 is directly connected, Ethernet0/0
L        22.0.12.2/32 is directly connected, Ethernet0/0
B        22.0.47.0/24 [20/0] via 21.0.23.3, 02:33:42
B     33.0.0.0/8 [200/0] via 22.0.7.7, 00:34:43
B     55.0.0.0/8 [200/0] via 22.0.7.7, 00:33:13


R2#sh ip bgp
BGP table version is 43, local router ID is 22.0.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
 *>i 8.0.0.0/16       22.0.7.7                 0    100      0 8 i
 *>i 11.0.0.0         22.0.7.7                 0    100      0 8 i
 *>  21.0.23.0/24     0.0.0.0                  0         32768 ?
 *>  21.0.23.3/32     0.0.0.0                  0         32768 ?
 *>i 22.0.0.0/16      22.0.7.7                 0    100      0 i
 *>  22.0.1.1/32      22.0.12.1               11         32768 ?
 *>  22.0.2.2/32      0.0.0.0                  0         32768 ?
 *>  22.0.4.4/32      21.0.23.3                              0 21 22 ?
 *>  22.0.7.7/32      21.0.23.3                              0 21 22 ?
 *>  22.0.12.0/24     0.0.0.0                  0         32768 ?
 *>  22.0.47.0/24     21.0.23.3                              0 21 22 ?
 *>i 33.0.0.0         22.0.7.7                 0    100      0 8 i
 *>i 55.0.0.0         22.0.7.7                 0    100      0 8 i

R2# show mpls forwarding-table
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
16         Pop Label  21.0.23.3/32     0             Et1/0      21.0.23.3
17         No Label   22.0.1.1/32      56365         Et0/0      22.0.12.1
18         No Label   8.0.0.0/16       0             Et1/0      21.0.23.3
19         No Label   11.0.0.0/8       0             Et1/0      21.0.23.3
20         No Label   33.0.0.0/8       0             Et1/0      21.0.23.3
21         No Label   22.0.0.0/16      0             Et1/0      21.0.23.3
23         No Label   55.0.0.0/8       0             Et1/0      21.0.23.3

RP/0/0/CPU0:ios#sho route vrf AS22
Sun Jan 17 11:38:47.321 UTC

Codes: C - connected, S - static, R - RIP, B - BGP, (>) - Diversion path
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - ISIS, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, su - IS-IS summary null, * - candidate default
       U - per-user static route, o - ODR, L - local, G  - DAGR, l - LISP
       A - access/subscriber, a - Application route
       M - mobile route, r - RPL, (!) - FRR Backup path

Gateway of last resort is not set

C    21.0.23.0/24 is directly connected, 03:37:04, GigabitEthernet0/0/0/0
S    21.0.23.2/32 is directly connected, 03:26:07, GigabitEthernet0/0/0/0
L    21.0.23.3/32 is directly connected, 03:37:04, GigabitEthernet0/0/0/0
B    22.0.0.0/16 [20/0] via 21.0.23.2, 00:45:28
B    22.0.1.1/32 [20/11] via 21.0.23.2, 03:21:00
B    22.0.2.2/32 [20/0] via 21.0.23.2, 03:21:00
B    22.0.4.4/32 [200/0] via 21.0.6.6 (nexthop in vrf default), 02:38:19
B    22.0.7.7/32 [200/2] via 21.0.6.6 (nexthop in vrf default), 02:38:19
B    22.0.12.0/24 [20/0] via 21.0.23.2, 03:21:00
B    22.0.47.0/24 [200/0] via 21.0.6.6 (nexthop in vrf default), 02:38:19


RP/0/0/CPU0:ios#sh ip route
Sun Jan 17 11:39:08.350 UTC

Codes: C - connected, S - static, R - RIP, B - BGP, (>) - Diversion path
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - ISIS, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, su - IS-IS summary null, * - candidate default
       U - per-user static route, o - ODR, L - local, G  - DAGR, l - LISP
       A - access/subscriber, a - Application route
       M - mobile route, r - RPL, (!) - FRR Backup path

Gateway of last resort is not set

L    21.0.3.3/32 is directly connected, 03:37:25, Loopback0
i L2 21.0.5.5/32 [115/20] via 21.0.35.5, 03:37:19, GigabitEthernet0/0/0/1
i L2 21.0.6.6/32 [115/30] via 21.0.35.5, 03:37:19, GigabitEthernet0/0/0/1
C    21.0.35.0/24 is directly connected, 03:37:25, GigabitEthernet0/0/0/1
L    21.0.35.3/32 is directly connected, 03:37:25, GigabitEthernet0/0/0/1
i L2 21.0.56.0/24 [115/20] via 21.0.35.5, 03:37:19, GigabitEthernet0/0/0/1


RP/0/0/CPU0:ios# show mpls forwarding vrf AS22
Sun Jan 17 11:39:26.108 UTC
Local  Outgoing    Prefix             Outgoing     Next Hop        Bytes
Label  Label       or ID              Interface                    Switched
------ ----------- ------------------ ------------ --------------- ------------
24004  Pop         21.0.23.2/32[V]    Gi0/0/0/0    21.0.23.2       369714
24006  17          22.0.1.1/32[V]     Gi0/0/0/0    21.0.23.2       304125
24007  Pop         22.0.2.2/32[V]     Gi0/0/0/0    21.0.23.2       44394
24008  Pop         22.0.12.0/24[V]    Gi0/0/0/0    21.0.23.2       0
24010  23          22.0.4.4/32[V]                  21.0.6.6        0
24011  19          22.0.7.7/32[V]                  21.0.6.6        318850
24012  22          22.0.47.0/24[V]                 21.0.6.6        0
24015  21          22.0.0.0/16[V]     Gi0/0/0/0    21.0.23.2       0


RP/0/0/CPU0:ios#show mpls forwarding
Sun Jan 17 11:39:40.817 UTC
Local  Outgoing    Prefix             Outgoing     Next Hop        Bytes
Label  Label       or ID              Interface                    Switched
------ ----------- ------------------ ------------ --------------- ------------
24000  16          21.0.6.6/32        Gi0/0/0/1    21.0.35.5       365084
24001  Pop         21.0.5.5/32        Gi0/0/0/1    21.0.35.5       47827
24002  Pop         21.0.56.0/24       Gi0/0/0/1    21.0.35.5       0
24004  Pop         21.0.23.2/32[V]    Gi0/0/0/0    21.0.23.2       369754
24006  17          22.0.1.1/32[V]     Gi0/0/0/0    21.0.23.2       304125
24007  Pop         22.0.2.2/32[V]     Gi0/0/0/0    21.0.23.2       44394
24008  Pop         22.0.12.0/24[V]    Gi0/0/0/0    21.0.23.2       0
24010  23          22.0.4.4/32[V]                  21.0.6.6        0
24011  19          22.0.7.7/32[V]                  21.0.6.6        318850
24012  22          22.0.47.0/24[V]                 21.0.6.6        0
24015  21          22.0.0.0/16[V]     Gi0/0/0/0    21.0.23.2       0


RP/0/0/CPU0:ios#sh ip route
Sun Jan 17 11:45:16.764 UTC

Codes: C - connected, S - static, R - RIP, B - BGP, (>) - Diversion path
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - ISIS, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, su - IS-IS summary null, * - candidate default
       U - per-user static route, o - ODR, L - local, G  - DAGR, l - LISP
       A - access/subscriber, a - Application route
       M - mobile route, r - RPL, (!) - FRR Backup path

Gateway of last resort is not set

B    8.0.0.0/16 [200/0] via 22.0.7.7, 00:45:50
O    8.0.78.0/24 [110/11] via 22.0.47.7, 03:43:29, GigabitEthernet0/0/0/0
B    11.0.0.0/8 [200/0] via 22.0.7.7, 00:45:50
C    21.0.46.0/24 is directly connected, 03:21:38, GigabitEthernet0/0/0/1
L    21.0.46.4/32 is directly connected, 03:21:38, GigabitEthernet0/0/0/1
S    21.0.46.6/32 is directly connected, 02:45:06, GigabitEthernet0/0/0/1
B    22.0.0.0/16 [200/0] via 22.0.7.7, 02:40:59
B    22.0.1.1/32 [20/0] via 21.0.46.6, 02:44:54
B    22.0.2.2/32 [20/0] via 21.0.46.6, 02:44:54
L    22.0.4.4/32 is directly connected, 03:43:37, Loopback0
O    22.0.7.7/32 [110/2] via 22.0.47.7, 03:43:29, GigabitEthernet0/0/0/0
B    22.0.12.0/24 [20/0] via 21.0.46.6, 02:44:54
C    22.0.47.0/24 is directly connected, 03:43:36, GigabitEthernet0/0/0/0
L    22.0.47.4/32 is directly connected, 03:43:36, GigabitEthernet0/0/0/0
B    33.0.0.0/8 [200/0] via 22.0.7.7, 00:45:50
B    55.0.0.0/8 [200/0] via 22.0.7.7, 00:44:19

RP/0/0/CPU0:ios#sho bgp ipv4 labeled-unicast advertised summary
Sun Jan 17 11:48:13.172 UTC
Network            Next Hop        From            Advertised to
8.0.78.0/24        21.0.46.4       Local           21.0.46.6
22.0.4.4/32        21.0.46.4       Local           21.0.46.6
22.0.7.7/32        21.0.46.4       Local           21.0.46.6
22.0.47.0/24       21.0.46.4       Local           21.0.46.6

Processed 4 prefixes, 4 paths


R5#                 sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      21.0.0.0/8 is variably subnetted, 7 subnets, 2 masks
i L2     21.0.3.3/32 [115/20] via 21.0.35.3, 03:48:17, Ethernet0/0
C        21.0.5.5/32 is directly connected, Loopback0
i L2     21.0.6.6/32 [115/20] via 21.0.56.6, 03:52:42, Ethernet0/1
C        21.0.35.0/24 is directly connected, Ethernet0/0
L        21.0.35.5/32 is directly connected, Ethernet0/0
C        21.0.56.0/24 is directly connected, Ethernet0/1
L        21.0.56.5/32 is directly connected, Ethernet0/1


R5#  show mpls forwarding-table
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
16         Pop Label  21.0.6.6/32      403766        Et0/1      21.0.56.6
17         Pop Label  21.0.3.3/32      403005        Et0/0      21.0.35.3

R6#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      21.0.0.0/8 is variably subnetted, 6 subnets, 2 masks
i L2     21.0.3.3/32 [115/30] via 21.0.56.5, 03:51:17, Ethernet0/0
i L2     21.0.5.5/32 [115/20] via 21.0.56.5, 03:55:42, Ethernet0/0
C        21.0.6.6/32 is directly connected, Loopback0
i L2     21.0.35.0/24 [115/20] via 21.0.56.5, 03:55:42, Ethernet0/0
C        21.0.56.0/24 is directly connected, Ethernet0/0
L        21.0.56.6/32 is directly connected, Ethernet0/0


R6# sh ip route vrf AS22

Routing Table: AS22
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      21.0.0.0/8 is variably subnetted, 3 subnets, 2 masks
C        21.0.46.0/24 is directly connected, Ethernet1/0
C        21.0.46.4/32 is directly connected, Ethernet1/0
L        21.0.46.6/32 is directly connected, Ethernet1/0
      22.0.0.0/8 is variably subnetted, 7 subnets, 3 masks
B        22.0.0.0/16 [200/0] via 21.0.3.3, 00:59:55
B        22.0.1.1/32 [200/11] via 21.0.3.3, 03:05:53
B        22.0.2.2/32 [200/0] via 21.0.3.3, 03:05:53
B        22.0.4.4/32 [20/0] via 21.0.46.4, 02:52:46
B        22.0.7.7/32 [20/2] via 21.0.46.4, 02:52:46
B        22.0.12.0/24 [200/0] via 21.0.3.3, 03:05:53
B        22.0.47.0/24 [20/0] via 21.0.46.4, 02:52:46


R6#show mpls forwarding-table
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
16         Pop Label  21.0.5.5/32      0             Et0/0      21.0.56.5
17         Pop Label  21.0.35.0/24     0             Et0/0      21.0.56.5
18         17         21.0.3.3/32      0             Et0/0      21.0.56.5
19         24007      22.0.7.7/32[V]   371527        Et1/0      21.0.46.4
20         24008      22.0.12.0/24[V]  0             Et0/0      21.0.56.5
22         Pop Label  22.0.47.0/24[V]  0             Et1/0      21.0.46.4
23         Pop Label  22.0.4.4/32[V]   0             Et1/0      21.0.46.4
24         24006      22.0.1.1/32[V]   357765        Et0/0      21.0.56.5
26         24007      22.0.2.2/32[V]   60867         Et0/0      21.0.56.5
31         24015      22.0.0.0/16[V]   0             Et0/0      21.0.56.5

R6#show mpls forwarding-table vrf AS22
Local      Outgoing   Prefix           Bytes Label   Outgoing   Next Hop
Label      Label      or Tunnel Id     Switched      interface
19         24007      22.0.7.7/32[V]   371527        Et1/0      21.0.46.4
20         24008      22.0.12.0/24[V]  0             Et0/0      21.0.56.5
22         Pop Label  22.0.47.0/24[V]  0             Et1/0      21.0.46.4
23         Pop Label  22.0.4.4/32[V]   0             Et1/0      21.0.46.4
24         24006      22.0.1.1/32[V]   357765        Et0/0      21.0.56.5
26         24007      22.0.2.2/32[V]   60867         Et0/0      21.0.56.5
31         24015      22.0.0.0/16[V]   0             Et0/0      21.0.56.5


R7#         sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is not set

      8.0.0.0/8 is variably subnetted, 3 subnets, 3 masks
B        8.0.0.0/16 [20/0] via 8.0.78.8, 04:01:50
C        8.0.78.0/24 is directly connected, Ethernet1/0
L        8.0.78.7/32 is directly connected, Ethernet1/0
B     11.0.0.0/8 [20/0] via 8.0.78.8, 04:01:50
      21.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
B        21.0.23.0/24 [200/0] via 22.0.2.2, 01:05:47
B        21.0.23.3/32 [200/0] via 22.0.2.2, 01:05:47
      22.0.0.0/8 is variably subnetted, 8 subnets, 3 masks
S        22.0.0.0/16 is directly connected, Null0
O E2     22.0.1.1/32 [110/1] via 22.0.47.4, 02:59:51, Ethernet0/0
O E2     22.0.2.2/32 [110/1] via 22.0.47.4, 02:59:51, Ethernet0/0
O        22.0.4.4/32 [110/11] via 22.0.47.4, 03:58:22, Ethernet0/0
C        22.0.7.7/32 is directly connected, Loopback0
O E2     22.0.12.0/24 [110/1] via 22.0.47.4, 02:59:51, Ethernet0/0
C        22.0.47.0/24 is directly connected, Ethernet0/0
L        22.0.47.7/32 is directly connected, Ethernet0/0
B     33.0.0.0/8 [20/0] via 8.0.78.8, 04:01:50
B     55.0.0.0/8 [20/0] via 8.0.78.8, 00:59:16





This post first appeared on CCIE Service Provider Workbook, please read the originial post: here

Share the post

L3VPN task #9. CSC, supporting an ISP carrier.

×

Subscribe to Ccie Service Provider Workbook

Get updates delivered right to your inbox!

Thank you for your subscription

×