Get Even More Visitors To Your Blog, Upgrade To A Business Listing >>

BGP task #4. BGP configuration tasks.

Topology:




Use configuration from BGP task #3 as initial configuration for this task.

Requirements: 

1. Configure new loopback interfaces on R8 :
    loopback1, ipv4 address 1.0.1.1/32
    loopback2, ipv4 address 2.0.2.2/32
    loopback3, ipv4 address 3.0.3.3/32
    loopback4, ipv4 address 4.0.4.4/32

2. Configure R8 to advertise the following prefixes to all eBGP neighbors:
    8.0.0.0/16, 1.0.0.0/16, 2.0.0.0/16, 3.0.0.0/16, 4.0.0.0/16
    Do not configure any new static routes on R8 to achieve this requirement. 
   
3. Prefix 2.0.0.0/16 should have "origin" path attribute of "incomplete".

4, R8 should also advertise prefix 0.0.0.0/0 to AS67 and AS5. Do not configure any new static routes to achieve this requirement. 

Solution:

Highlight the text below to reveal the solution.

This task requires understanding of BGP aggregation, including attribute maps and suppression. 

Requirement #2 - since static routes are not allowed, install the loopback 1 - 4 adressess into BGP using redistribution or network command, then configure aggregation with suppress-map to filter out the /32 prefixes. 

Requirement #3 - use attribute-map to set the required origin attribute on aggregate address. 

Requirement #4 - use default-originate on R8 to neighbors. 

R8: 

!
route-map CONNECTED permit 100
 match interface Loopback1 Loopback2 Loopback3 Loopback4
!
!
ip prefix-list LOOPBACKS seq 5 permit 1.0.1.1/32
ip prefix-list LOOPBACKS seq 10 permit 2.0.2.2/32
ip prefix-list LOOPBACKS seq 15 permit 3.0.3.3/32
ip prefix-list LOOPBACKS seq 20 permit 4.0.4.4/32
!
!
route-map SUPP permit 10
 match ip address prefix-list LOOPBACKS
!
route-map ATTR permit 10
 set origin incomplete
!
!
router bgp 8
 bgp log-neighbor-changes
 aggregate-address 2.0.0.0 255.255.0.0 attribute-map ATTR suppress-map SUPP
 aggregate-address 4.0.0.0 255.255.0.0 suppress-map SUPP
 aggregate-address 3.0.0.0 255.255.0.0 suppress-map SUPP
 aggregate-address 1.0.0.0 255.255.0.0 suppress-map SUPP
 redistribute connected route-map CONNECTED
 redistribute static route-map STATIC
 neighbor 8.0.58.5 remote-as 5
 neighbor 8.0.58.5 password STRONG
 neighbor 8.0.58.5 default-originate
 neighbor 8.0.68.6 remote-as 67
 neighbor 8.0.68.6 default-originate
 neighbor 8.0.78.7 remote-as 67
 neighbor 8.0.78.7 default-originate
!




Verification:


R8#  sh ip bgp
BGP table version is 35, local router ID is 8.0.8.8
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal,
              r RIB-failure, S Stale, m multipath, b backup-path, f RT-Filter,
              x best-external, a additional-path, c RIB-compressed,
Origin codes: i - IGP, e - EGP, ? - incomplete
RPKI validation codes: V valid, I invalid, N Not found

     Network          Next Hop            Metric LocPrf Weight Path
     0.0.0.0          0.0.0.0                                0 i
 *>  1.0.0.0/16       0.0.0.0                            32768 i
 s>  1.0.1.1/32       0.0.0.0                  0         32768 ?
 *>  2.0.0.0/16       0.0.0.0                            32768 ?
 s>  2.0.2.2/32       0.0.0.0                  0         32768 ?
 *>  3.0.0.0/16       0.0.0.0                            32768 i
 s>  3.0.3.3/32       0.0.0.0                  0         32768 ?
 *>  4.0.0.0/16       0.0.0.0                            32768 i
 s>  4.0.4.4/32       0.0.0.0                  0         32768 ?
 *>  5.0.0.0/16       8.0.58.5                 0             0 5 i
 *>  8.0.0.0/16       0.0.0.0                  0         32768 ?
 *   12.0.0.0/16      8.0.78.7                               0 67 12 i
 *>                   8.0.68.6                               0 67 12 i
 *   67.0.0.0/16      8.0.78.7                 0             0 67 i

R8#sh ip bgp 1.0.1.1/32
BGP routing table entry for 1.0.1.1/32, version 33
Paths: (1 available, best #1, table default, Advertisements suppressed by an aggregate.)
  Not advertised to any peer
  Refresh Epoch 1
  Local
    0.0.0.0 from 0.0.0.0 (8.0.8.8)
      Origin incomplete, metric 0, localpref 100, weight 32768, valid, sourced, best




RP/0/0/CPU0:R3#show bgp
Tue Dec 22 11:28:48.939 UTC
BGP router identifier 12.0.3.3, local AS number 12
BGP generic scan interval 60 secs
BGP table state: Active
Table ID: 0xe0000000   RD version: 152
BGP main routing table version 152
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
              i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
   Network            Next Hop            Metric LocPrf Weight Path
* i0.0.0.0/0          5.0.15.5                 0    100      0 5 8 i
*>                    67.0.36.6                              0 67 8 i
*                     67.0.37.7                              0 67 8 i
* i1.0.0.0/16         5.0.15.5                 0    100      0 5 8 i
*>                    67.0.36.6                              0 67 8 i
*                     67.0.37.7                              0 67 8 i
* i2.0.0.0/16         5.0.15.5                 0    100      0 5 8 ?
*>                    67.0.36.6                              0 67 8 ?
*                     67.0.37.7                              0 67 8 ?
* i3.0.0.0/16         5.0.15.5                 0    100      0 5 8 i
*>                    67.0.36.6                              0 67 8 i
*                     67.0.37.7                              0 67 8 i
* i4.0.0.0/16         5.0.15.5                 0    100      0 5 8 i
*>                    67.0.36.6                              0 67 8 i
*                     67.0.37.7                              0 67 8 i
*>i5.0.0.0/16         5.0.15.5                 0    100      0 5 i
*                     67.0.36.6                              0 67 8 5 i
*                     67.0.37.7                              0 67 8 5 i
*  8.0.0.0/16         67.0.36.6                     200      0 67 8 ?
*>                    67.0.37.7                     300      0 67 8 ?
*>i12.0.0.0/16        12.0.2.2                 0    100      0 i
* i                   12.0.4.4                 0    100      0 i
*  67.0.0.0/16        67.0.36.6            10000             0 67 i
*>                    67.0.37.7             1000             0 67 i




This post first appeared on CCIE Service Provider Workbook, please read the originial post: here

Share the post

BGP task #4. BGP configuration tasks.

×

Subscribe to Ccie Service Provider Workbook

Get updates delivered right to your inbox!

Thank you for your subscription

×