Get Even More Visitors To Your Blog, Upgrade To A Business Listing >>

ISIS task #4. Dual stack.

Topology:



Use configuration from ISIS task #3 as initial configuration for this task.

Requirements: 

1. Enable IPv6 unicast routing on all routers, and configure the interfaces using assigned IPv6 prefix. 
2. Configure the network to provide full IPv4 and IPv6 connectivity. Use minimal amount of memory and CPU resources.
3. Create two new loopback interfaces on R2.
         loopback2, ipv4 address 2.0.1.1/24
         loopback3, ipv4 address 2.0.2.2/24
    Do not enable ISIS on those interfaces. The interfaces should be reachable from all routers. All           routers except R2, should only have one (1) entry in routing table to reach those two prefixes.

4. Create two new loopback interfaces on R5.
         loopback2, ipv6 address 2001:4:0:1::1/64
         loopback3, ipv6 address 2001:4:0:2::2/64
     Do not enable ISIS on those interfaces. The interfaces should be reachable from all routers. All            routers except R5, should only have one (1) entry in routing table to reach those two prefixes.

Solution:

Highlight the text below to reveal the solution.

Requirement #1 & 2 - Use the existing ISIS process do distribute IPv4 and IPv6 routing information. Since all interfaces are configured with both IPv4 and IPv6 addresses, use "single-topology" to save CPU and memory resources. 

Requirement #3 & 4 - redistribute connected interfaces into ISIS Level-2 and use summary-address. 


R1: 


!
interface Loopback0
 ip address 11.0.1.1 255.255.255.255
 ip router isis CCIE
 ipv6 address 2001:11:0:1::1/64
 ipv6 router isis CCIE
 isis circuit-type level-2-only
!
interface Ethernet0/0
 ip address 11.0.13.1 255.255.255.0
 ip router isis CCIE
 ipv6 address 2001:11:0:13::1/64
 ipv6 router isis CCIE
 isis circuit-type level-2-only
 isis hello-interval 3
 isis csnp-interval 5
!
interface Ethernet0/1
 ip address 11.0.12.1 255.255.255.0
 ip router isis CCIE
 ipv6 address 2001:11:0:12::1/64
 ipv6 router isis CCIE
 isis circuit-type level-2-only
 isis network point-to-point
!
!
interface Ethernet1/0
 ip address 11.0.18.1 255.255.255.0
 ip router isis CCIE
 ipv6 address 2001:11:0:18::1/64
 ipv6 router isis CCIE
 isis password HPASS
!
!
router isis CCIE
 net 49.0001.0000.0000.0001.00
 authentication mode md5
 authentication key-chain CHAIN level-2
 metric-style wide
 max-lsp-lifetime 65535
 lsp-refresh-interval 65000
 spf-interval 5 2750 2750
 prc-interval 5 2750 2750
!

R2: 


!
interface Loopback0
 ip address 11.0.2.2 255.255.255.255
 ip router isis CCIE
 ipv6 address 2001:11:0:2::2/64
 ipv6 router isis CCIE
 isis circuit-type level-2-only
!
interface Loopback2
 ip address 2.0.1.1 255.255.255.0
!
interface Loopback3
 ip address 2.0.2.2 255.255.255.0
!
interface Ethernet0/0
 ip address 11.0.23.2 255.255.255.0
 ip router isis CCIE
 ipv6 address 2001:11:0:23::2/64
 ipv6 router isis CCIE
 isis circuit-type level-2-only
 isis priority 127
!
interface Ethernet0/1
 ip address 11.0.12.2 255.255.255.0
 ip router isis CCIE
 ipv6 address 2001:11:0:12::2/64
 ipv6 router isis CCIE
 isis circuit-type level-2-only
 isis network point-to-point
!
!
interface Ethernet1/0
 ip address 11.0.24.2 255.255.255.0
 ip router isis CCIE
 ipv6 address 2001:11:0:24::2/64
 ipv6 router isis CCIE
!
!
router isis CCIE
 net 49.0001.0000.0000.0002.00
 authentication mode md5
 authentication key-chain CHAIN level-2
 metric-style wide
 max-lsp-lifetime 65535
 lsp-refresh-interval 65000
 spf-interval 5 2750 2750
 prc-interval 5 2750 2750
 summary-address 2.0.0.0 255.255.252.0
 redistribute connected route-map CONNECTED_V4
!
!
ip prefix-list CONNECTED_V4 seq 5 permit 2.0.1.0/24
ip prefix-list CONNECTED_V4 seq 10 permit 2.0.2.0/24
!
route-map CONNECTED_V4 permit 100
 match ip address prefix-list CONNECTED_V4
!


R3: 


!
router isis CCIE
 net 49.0001.0000.0000.0003.00
 lsp-refresh-interval 65000
 max-lsp-lifetime 65535
 lsp-password keychain CHAIN level 2
 address-family ipv4 unicast
  metric-style wide
  default-information originate
 !
 address-family ipv6 unicast
  metric-style wide
  single-topology
 !
 interface Loopback0
  address-family ipv4 unicast
  !
  address-family ipv6 unicast
  !
 !
 interface GigabitEthernet0/0/0/0
  circuit-type level-2-only
  priority 127
  csnp-interval 5
  hello-interval 3
  address-family ipv4 unicast
  !
  address-family ipv6 unicast
  !
 !
 interface GigabitEthernet0/0/0/1
  circuit-type level-2-only
  address-family ipv4 unicast
  !
  address-family ipv6 unicast
  !
 !
 interface GigabitEthernet0/0/0/2
  address-family ipv4 unicast
  !
  address-family ipv6 unicast
  !
 !
!

R4: 

!
interface Loopback0
 ip address 11.0.4.4 255.255.255.255
 ip router isis CCIE
 ip ospf network point-to-point
 ipv6 address 2001:11:0:4::4/64
 ipv6 router isis CCIE
!
interface Ethernet0/0
 ip address 11.0.45.4 255.255.255.0
 ip router isis CCIE
 ipv6 address 2001:11:0:45::4/64
 isis circuit-type level-1
!
interface Ethernet0/1
 ip address 11.0.24.4 255.255.255.0
 ip router isis CCIE
 ipv6 address 2001:11:0:24::4/64
 ipv6 router isis CCIE
!
interface Ethernet0/2
 ip address 11.0.47.4 255.255.255.0
 ip router isis CCIE
 ipv6 address 2001:11:0:47::4/64
 ipv6 router isis CCIE
 isis circuit-type level-1
!
!
interface Ethernet1/0
 ip address 11.0.46.4 255.255.255.0
 ip router isis CCIE
 ipv6 address 2001:11:0:46::4/64
 ipv6 router isis CCIE
 isis circuit-type level-1
!
!
router isis CCIE
 net 49.0003.0000.0000.0004.00
 authentication mode text level-1
 authentication mode md5 level-2
 authentication key-chain CHAIN2 level-1
 authentication key-chain CHAIN level-2
 metric-style wide
 max-lsp-lifetime 65535
 lsp-refresh-interval 65000
 spf-interval 5 2750 2750
 prc-interval 5 2750 2750
 redistribute isis ip level-2 into level-1 route-map LEAK
!

R5:

!
router isis CCIE
 net 49.0003.0000.0000.0005.00
 lsp-refresh-interval 65000
 max-lsp-lifetime 65535
 lsp-password text encrypted 047A39232E72 level 1
 lsp-password keychain CHAIN level 2
 address-family ipv4 unicast
  metric-style wide
  propagate level 2 into level 1 route-policy LEAK
 !
 address-family ipv6 unicast
  metric-style wide
  summary-prefix 2001:4::/62 level 2
  single-topology
  redistribute connected level-2 route-policy LOOPBACLS_V6
 !
 interface Loopback0
  address-family ipv4 unicast
  !
  address-family ipv6 unicast
  !
 !
 interface GigabitEthernet0/0/0/0
  circuit-type level-1
  address-family ipv4 unicast
  !
  address-family ipv6 unicast
  !
 !
 interface GigabitEthernet0/0/0/1
  circuit-type level-1
  address-family ipv4 unicast
  !
  address-family ipv6 unicast
  !
 !
 interface GigabitEthernet0/0/0/2
  address-family ipv4 unicast
  !
  address-family ipv6 unicast
  !
 !
!
!
prefix-set LOOPBACKS_V6
  2001:4:0:1::/64,
  2001:4:0:2::/64
end-set
!
!
route-policy LOOPBACLS_V6
  if destination in LOOPBACKS_V6 then
    pass
  endif
end-policy
!


R6:

!
interface Loopback0
 ip address 11.0.6.6 255.255.255.255
 ip router isis CCIE
 ip ospf network point-to-point
 ipv6 address 2001:11:0:6::6/64
 ipv6 router isis CCIE
!
interface Ethernet0/0
 ip address 11.0.67.6 255.255.255.0
 ip router isis CCIE
 ipv6 address 2001:11:0:67::6/64
 ipv6 router isis CCIE
!
interface Ethernet0/1
 ip address 11.0.46.6 255.255.255.0
 ip router isis CCIE
 ipv6 address 2001:11:0:46::6/64
 ipv6 router isis CCIE
!
!
router isis CCIE
 net 49.0003.0000.0000.0006.00
 is-type level-1
 area-password AREA3 authenticate snp validate
 metric-style wide
 max-lsp-lifetime 65535
 lsp-refresh-interval 65000
 spf-interval 5 2750 2750
 prc-interval 5 2750 2750
!

R7:

!
interface Loopback0
 ip address 11.0.7.7 255.255.255.255
 ip router isis CCIE
 ip ospf network point-to-point
 ipv6 address 2001:11:0:7::7/64
 ipv6 router isis CCIE
!
interface Ethernet0/0
 ip address 11.0.67.7 255.255.255.0
 ip router isis CCIE
 ipv6 address 2001:11:0:67::7/64
 ipv6 router isis CCIE
!
interface Ethernet0/1
 ip address 11.0.57.7 255.255.255.0
 ip router isis CCIE
 ipv6 address 2001:11:0:57::7/64
 ipv6 router isis CCIE
!
interface Ethernet0/2
 ip address 11.0.47.7 255.255.255.0
 ip router isis CCIE
 ipv6 address 2001:11:0:47::7/64
 ipv6 router isis CCIE
!
!
router isis CCIE
 net 49.0003.0000.0000.0007.00
 is-type level-1
 area-password AREA3 authenticate snp validate
 metric-style wide
 spf-interval 5 2750 2750
 prc-interval 5 2750 2750
!


R8:

!
interface Loopback0
 ip address 11.0.8.8 255.255.255.255
 ip router isis CCIE
 ip ospf network point-to-point
 ipv6 address 2001:11:0:8::8/64
 ipv6 router isis CCIE
!
interface Loopback16
 ip address 11.0.16.16 255.255.255.0
 ip router isis CCIE
 ipv6 address 2001:11:0:16::16/64
 ipv6 router isis CCIE
!
interface Loopback17
 ip address 11.0.17.17 255.255.255.0
 ip router isis CCIE
 ipv6 address 2001:11:0:17::17/64
 ipv6 router isis CCIE
!
interface Ethernet0/0
 ip address 11.0.18.8 255.255.255.0
 ip router isis CCIE
 ip ospf network point-to-point
 ip ospf demand-circuit
 ipv6 address 2001:11:0:18::8/64
 ipv6 router isis CCIE
 isis password HPASS
!
!
router isis CCIE
 net 49.0002.0000.0000.0008.00
 authentication mode md5
 authentication key-chain CHAIN level-2
 metric-style wide
 max-lsp-lifetime 65535
 lsp-refresh-interval 65000
 spf-interval 5 2750 2750
 prc-interval 5 2750 2750
 summary-address 11.0.16.0 255.255.254.0
!




Verification:

R8#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
       + - replicated route, % - next hop override

Gateway of last resort is 11.0.18.1 to network 0.0.0.0

i*L2  0.0.0.0/0 [115/20] via 11.0.18.1, 21:26:40, Ethernet0/0
      2.0.0.0/22 is subnetted, 1 subnets
i L2     2.0.0.0 [115/20] via 11.0.18.1, 00:23:59, Ethernet0/0
      11.0.0.0/8 is variably subnetted, 25 subnets, 3 masks
i L2     11.0.1.1/32 [115/20] via 11.0.18.1, 21:27:47, Ethernet0/0
i L2     11.0.2.2/32 [115/30] via 11.0.18.1, 21:27:39, Ethernet0/0
i L2     11.0.3.3/32 [115/30] via 11.0.18.1, 21:26:47, Ethernet0/0
i L2     11.0.4.4/32 [115/40] via 11.0.18.1, 21:27:27, Ethernet0/0
i L2     11.0.5.5/32 [115/40] via 11.0.18.1, 21:26:35, Ethernet0/0
i L2     11.0.6.6/32 [115/50] via 11.0.18.1, 21:27:08, Ethernet0/0
i L2     11.0.7.7/32 [115/50] via 11.0.18.1, 21:20:08, Ethernet0/0
C        11.0.8.8/32 is directly connected, Loopback0
i L2     11.0.12.0/24 [115/20] via 11.0.18.1, 21:27:47, Ethernet0/0
i L2     11.0.13.0/24 [115/20] via 11.0.18.1, 21:27:47, Ethernet0/0
i su     11.0.16.0/23 [115/10] via 0.0.0.0, 21:17:25, Null0
C        11.0.16.0/24 is directly connected, Loopback16
L        11.0.16.16/32 is directly connected, Loopback16
C        11.0.17.0/24 is directly connected, Loopback17
L        11.0.17.17/32 is directly connected, Loopback17
C        11.0.18.0/24 is directly connected, Ethernet0/0
L        11.0.18.8/32 is directly connected, Ethernet0/0
i L2     11.0.23.0/24 [115/30] via 11.0.18.1, 21:26:47, Ethernet0/0
i L2     11.0.24.0/24 [115/30] via 11.0.18.1, 21:27:39, Ethernet0/0
i L2     11.0.35.0/24 [115/30] via 11.0.18.1, 21:26:47, Ethernet0/0
i L2     11.0.45.0/24 [115/40] via 11.0.18.1, 21:26:25, Ethernet0/0
i L2     11.0.46.0/24 [115/40] via 11.0.18.1, 21:27:27, Ethernet0/0
i L2     11.0.47.0/24 [115/40] via 11.0.18.1, 21:27:27, Ethernet0/0
i L2     11.0.57.0/24 [115/40] via 11.0.18.1, 21:26:25, Ethernet0/0
i L2     11.0.67.0/24 [115/50] via 11.0.18.1, 21:20:08, Ethernet0/0

R8# sh ipv6 route
IPv6 Routing Table - default - 27 entries
Codes: C - Connected, L - Local, S - Static, U - Per-user Static route
       B - BGP, HA - Home Agent, MR - Mobile Router, R - RIP
       H - NHRP, I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea
       IS - ISIS summary, D - EIGRP, EX - EIGRP external, NM - NEMO
       ND - ND Default, NDp - ND Prefix, DCE - Destination, NDr - Redirect
       O - OSPF Intra, OI - OSPF Inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2, l - LISP
I2  2001:4::/62 [115/30]
     via FE80::A8BB:CCFF:FE00:601, Ethernet0/0
I2  2001:11:0:1::/64 [115/20]
     via FE80::A8BB:CCFF:FE00:601, Ethernet0/0
I2  2001:11:0:2::/64 [115/30]
     via FE80::A8BB:CCFF:FE00:601, Ethernet0/0
I2  2001:11:0:3::/64 [115/30]
     via FE80::A8BB:CCFF:FE00:601, Ethernet0/0
I2  2001:11:0:4::/64 [115/40]
     via FE80::A8BB:CCFF:FE00:601, Ethernet0/0
I2  2001:11:0:5::/64 [115/40]
     via FE80::A8BB:CCFF:FE00:601, Ethernet0/0
I2  2001:11:0:6::/64 [115/50]
     via FE80::A8BB:CCFF:FE00:601, Ethernet0/0
I2  2001:11:0:7::/64 [115/50]
     via FE80::A8BB:CCFF:FE00:601, Ethernet0/0
C   2001:11:0:8::/64 [0/0]
     via Loopback0, directly connected
L   2001:11:0:8::8/128 [0/0]
     via Loopback0, receive
I2  2001:11:0:12::/64 [115/20]
     via FE80::A8BB:CCFF:FE00:601, Ethernet0/0
I2  2001:11:0:13::/64 [115/20]
     via FE80::A8BB:CCFF:FE00:601, Ethernet0/0
C   2001:11:0:16::/64 [0/0]
     via Loopback16, directly connected
L   2001:11:0:16::16/128 [0/0]
     via Loopback16, receive
C   2001:11:0:17::/64 [0/0]
     via Loopback17, directly connected
L   2001:11:0:17::17/128 [0/0]
     via Loopback17, receive
C   2001:11:0:18::/64 [0/0]
     via Ethernet0/0, directly connected
L   2001:11:0:18::8/128 [0/0]
     via Ethernet0/0, receive
I2  2001:11:0:23::/64 [115/30]
     via FE80::A8BB:CCFF:FE00:601, Ethernet0/0
I2  2001:11:0:24::/64 [115/30]
     via FE80::A8BB:CCFF:FE00:601, Ethernet0/0
I2  2001:11:0:35::/64 [115/30]
     via FE80::A8BB:CCFF:FE00:601, Ethernet0/0
I2  2001:11:0:45::/64 [115/40]
     via FE80::A8BB:CCFF:FE00:601, Ethernet0/0
I2  2001:11:0:46::/64 [115/40]
     via FE80::A8BB:CCFF:FE00:601, Ethernet0/0
I2  2001:11:0:47::/64 [115/40]
     via FE80::A8BB:CCFF:FE00:601, Ethernet0/0
I2  2001:11:0:57::/64 [115/40]
     via FE80::A8BB:CCFF:FE00:601, Ethernet0/0
I2  2001:11:0:67::/64 [115/50]
     via FE80::A8BB:CCFF:FE00:601, Ethernet0/0
L   FF00::/8 [0/0]
     via Null0, receive





This post first appeared on CCIE Service Provider Workbook, please read the originial post: here

Share the post

ISIS task #4. Dual stack.

×

Subscribe to Ccie Service Provider Workbook

Get updates delivered right to your inbox!

Thank you for your subscription

×