Get Even More Visitors To Your Blog, Upgrade To A Business Listing >>

upgraded node to v0.8 and started receiving an error for sys/util

upgraded node to v0.8 and started receiving an error for sys/util

Problem

I upgraded from Node v0.6.12 to 0.80 and started receiving the Error below - I have removed the sys module from the import but am still getting the error. Any helpful hints would be helpful. I am not suing stylus either.

path.exists is now called `fs.exists`.

sys.js:1

throw new Error(

Error: The "sys" module is now called "util".
at sys.js:1:69
at NativeModule.compile (node.js:602:5)
at Function.NativeModule.require (node.js:570:18)
at Function.Module._load (module.js:297:25)
at Module.require (module.js:362:17)
at require (module.js:378:17)
at Object. (/node/node_modules/stylus/lib/token.js:12:15)
at Module._compile (module.js:449:26)
at Object.Module._extensions..js (module.js:467:10)
at Module.load (module.js:356:32)
Problem courtesy of: ali haider

Solution

Upgrade to node v0.8.1. It will solve your problem

Solution courtesy of: Pavan Kumar Sunkara

Discussion

View additional discussion.



This post first appeared on Node.js Recipes, please read the originial post: here

Share the post

upgraded node to v0.8 and started receiving an error for sys/util

×

Subscribe to Node.js Recipes

Get updates delivered right to your inbox!

Thank you for your subscription

×