Get Even More Visitors To Your Blog, Upgrade To A Business Listing >>

nowjs/node-proxy fails to install on ubuntu 11.10

nowjs/node-proxy fails to install on ubuntu 11.10

Problem

I'm trying to install now.js on ubuntu 11.10 (running on windows with wubi, if that matters). I've downloaded and installed node, npm, and socket.io just fine, but sudo npm install now fails for some reason. I've tried with and without sudo, tried installing it globally, same error. Make is installed just fine...is it some problem with the node-proxy package? For what it's worth, trying npm install node-proxy produces a similar error.

node version 0.6.2
npm version 1.0.106
ubuntu 11.10 (windows with wubi)

The log reads, when I try to install now:

npm WARN [email protected] package.json: bugs['web'] should probably be bugs['url']

> [email protected] install /home/my_name/node_modules/now/node_modules/node-proxy
> make

BUILDING: C++ Component
/bin/sh: node-waf: not found
cp: cannot stat `src/build/*/node-proxy.node': No such file or directory
make: *** [all] Error 1
npm ERR! error installing [email protected] Error: [email protected] install: `make`
npm ERR! error installing [email protected] `sh "-c" "make"` failed with 2
npm ERR! error installing [email protected]     at ChildProcess. (/usr/lib/node_modules/npm/lib/utils/exec.js:49:20)
npm ERR! error installing [email protected]     at ChildProcess.emit (events.js:70:17)
npm ERR! error installing [email protected]     at maybeExit (child_process.js:359:16)
npm ERR! error installing [email protected]     at Process.onexit (child_process.js:395:5)
npm ERR! error installing [email protected] Error: [email protected] install: `make`
npm ERR! error installing [email protected] `sh "-c" "make"` failed with 2
npm ERR! error installing [email protected]     at ChildProcess. (/usr/lib/node_modules/npm/lib/utils/exec.js:49:20)
npm ERR! error installing [email protected]     at ChildProcess.emit (events.js:70:17)
npm ERR! error installing [email protected]     at maybeExit (child_process.js:359:16)
npm ERR! error installing [email protected]     at Process.onexit (child_process.js:395:5)
npm ERR! [email protected] install: `make`
npm ERR! `sh "-c" "make"` failed with 2
npm ERR! 
npm ERR! Failed at the [email protected] install script.
npm ERR! This is most likely a problem with the node-proxy package,
npm ERR! not with npm itself.
npm ERR! Tell the author that this fails on your system:
npm ERR!     make
npm ERR! You can get their info via:
npm ERR!     npm owner ls node-proxy
npm ERR! There is likely additional logging output above.
npm ERR! 
npm ERR! System Linux 3.0.0-13-generic
npm ERR! command "node" "/usr/bin/npm" "install" "now"
npm ERR! cwd /home/my_name
npm ERR! node -v v0.6.2
npm ERR! npm -v 1.0.106
npm ERR! code ELIFECYCLE
npm ERR! 
npm ERR! Additional logging details can be found in:
npm ERR!     /home/my_name/npm-debug.log
npm not ok
Problem courtesy of: Noah Gilmore

Solution

The issue appears to be that node-waf is missing.

node-waf is a tool that is included with node which allows compiling binary modules, such as node-proxy.

You can test to see if node-waf is available simply by typing node-waf into the terminal to see if the command can be found. If not, you will need to reinstall node (run make install again) to make sure node-waf is available.

Solution courtesy of: Eric Zhang

Discussion

View additional discussion.



This post first appeared on Node.js Recipes, please read the originial post: here

Share the post

nowjs/node-proxy fails to install on ubuntu 11.10

×

Subscribe to Node.js Recipes

Get updates delivered right to your inbox!

Thank you for your subscription

×